Web Hosting problem after switching to Panther Server

Discussion in 'Mac Apps and Mac App Store' started by crashtd, Nov 8, 2003.

  1. crashtd macrumors newbie

    Nov 2, 2003
    Santa Barbara
    So i go and load Panther Server up today (upgrading from Jaguar...which i was less than thrilled about). All my settings xfer'd over except for my sites. I'm vhosting about 20 or so. No biggie i think, if i something had to go wrong, atleast its this, easy fix...not quite.

    I try adding them in manually in Server Admin, but i get an odd error. As i'm filling in fields. It'll keep telling me so and so field can't be left blank, when i haven't even gotten to that tab yet! I finally fill everything out, hit save and it says:

    "Sorry but the feature you tried to access cannot be used. You may write a bug against “Server Admin Web/X Server”. Exception is:

    In updateDescriptionFromConfigurationView: NSInvalidArgumentException *** -[NSCFDictionary setObject:forKey:]: attempt to insert nil value ."

    i have a backup of my httpd_macosxserver.conf, tried swapping it...no luck!

    anyone have a clue what's going on? i going nuts trying to sort this out.

  2. cbrookes macrumors newbie

    Dec 10, 2003
    I have exactly the same problem. The admin tool also messes up other settings (for example if FORCED me to define a cache path even though I didnt want to use the cache) and the upgrade doesnt remove the apple modules that were required by jaguar - which also stops apache from starting and can only be removed by hand.

    All in all a damn poor job from apple with the upgrade.

    If you find a solution then I would appreciate any tips...

  3. cbrookes macrumors newbie

    Dec 10, 2003
    I saw in the readme.txt file that there was a description for a file called:
    0000_any_80_.conf and that this contains the default config info for the site.
    On my machine this file didnt exist - so I created it by copying the one from sites_disabled, changing the vhost name and server name.

    Then the error message stopped appearing AND I had my site suddenly popup in the list.

    The second part was that in the readme it "claimed" that all the files in the sites folder were read by apache at startup due to an Include statement in the apache config file. This include statement also didnt exist, so I added it manually.

    Not everything is working yet - but this is definately going in the right direction.
  4. sdoenges macrumors newbie

    Dec 18, 2003
    I just upgraded a Mac OS X 10.2 Server to 10.3 Server and I'm seeing this same problem. All of my sites are gone, and I can't seem to get them back. I didn't have a "0000_any_80_.conf" file in sites_disabled, so I'm not sure what to do.

    Have either of you managed to find a fix for this problem with 10.3 Server? Any other suggestions?

    And I thought it would be a simple upgrade.....

  5. sdoenges macrumors newbie

    Dec 18, 2003
    Actually I may have found a solution to this. I moved /etc/httpd/httpd.conf to my desktop (just in case), then rebooted the server. When I went back into Server Admin, two of my three sites were back. It didn't give me any errors when I recreated my third site.

    However I did have to uncheck then recheck the "enabled" box on each site in Server Admin to make them actually go live again. Very weird...

Share This Page