web-kit framework accidentally deleted

Discussion in 'Mac Apps and Mac App Store' started by steelfist, Feb 23, 2006.

  1. steelfist macrumors 6502a

    Aug 10, 2005
    in /system/libary/frameworks/webkit.framework, i backed up the files by dragging them to the desktop. i thought i copied them, but after messing with them i realized that i only created aliases to them. so the entire webkit is deleted. i tried to replace the webkit folder with the webkit stuff that was from the open source webkit development. how do i restore the original files?
  2. steelfist thread starter macrumors 6502a

    Aug 10, 2005
    i apologize if i am breaking the forum rules, but this is urgent.

    i have webkit.framework empty, and over a dozen applications will not start. :mad:
  3. dr_lha macrumors 68000

    Oct 8, 2003
    You'll probably have to reinstall the OS, unless you have another Mac to copy the files off.

    You basically just chucked a major part of the OS in the trash there. What on Earth were you doing?
  4. robbieduncan Moderator emeritus


    Jul 24, 2002
    You could download the current CVS development one from the project site and build it. Note that this would be a later version that what is currently shipped and will almost certainly have bugs.

    Apart from that it's reinstall time, or try and extract the individual Framework from the installer CD.

    And be more careful next time.
  5. steelfist thread starter macrumors 6502a

    Aug 10, 2005
    i was trying to back up the files from the webkit to another folder, and use that same site's webkit installed. unfortunatly, it didn't worked. and, unfortunatly, i lost it.
  6. ITASOR macrumors 601


    Mar 20, 2005

    I can zip mine up and give you a download link if you'd like...will that work?

    edit: This is just another reason why you shouldn't run on an admin account all the time, I guess.

    here's a link: http://itasor.com/WebKit.framework.zip

    hope that helps you.

Share This Page