Web Kit Render Error -- have you ever seen this?

Discussion in 'Web Design and Development' started by savar, Sep 7, 2010.

  1. savar macrumors 68000

    savar

    Joined:
    Jun 6, 2003
    Location:
    District of Columbia
    #1
    I work on a web app that renders correctly in IE and Firefox, but for some reason every once in a while it bugs out on my in Web Kit browsers like Safari and Chrome. It doesn't do it every time, and whenever I see this issue I just hit refresh and it goes away, but it's starting to drive me crazy.

    I don't get this error on any other site, either, so I can't figure out what it is.

    The gist of this error is that occasionally Safari will render some part of the <HEAD> tag into the page, although I can clearly see in the document source that the <HEAD> tag and its contents are well-formed.

    I've been seeing this error intermittently for over 2 years, including both Safari 4 and Safari 5. The page in question is encoded in UTF-8, although in practice it never contains anything outside of UTF-8's single byte encoding (i.e. basic ASCII).

    [​IMG]

    Hopefully somebody here has seen this and can provide some feedback. <fingers crossed>
     
  2. eponym macrumors 6502

    Joined:
    Jul 2, 2010
    #2
    Without posting the actual code, or a link to a file, nobody will be able to accurately help you.

    But my first reaction:

    :confused::confused::eek: @ trying to load in dozens of separate js files
     
  3. savar thread starter macrumors 68000

    savar

    Joined:
    Jun 6, 2003
    Location:
    District of Columbia
    #3
    Well, I don't think it's a problem with the source, since the problem is intermittent. 19 times out of 20, the same exact HTML source renders fine, but 5% of the time it hiccups.

    I was hoping this was somebody else had seen this before and would recognize it at first sight. This problem is too weird for it to have some simple explanation, *I think*.

    Anyway, I attached the source for the page in the screenshot.

    In production mode we send a single, minified JS file, but that's not easy to debug :) So when I develop I run it in debug mode, which sends the debuggable version of each JS file.

    I could see this being a potential problem, but I sometimes get the same error even when I switch to the single, minified JS file, so evidently that's not the root cause.

    Edit: Also, here is a link to a demo version which we have up on our site: http://demo.openfisma.org. It's an open source app, so if you look at our website you'll find all of the source code.
     

    Attached Files:

Share This Page