Web server question

Discussion in 'Web Design and Development' started by makatak88, Mar 11, 2008.

  1. makatak88 macrumors newbie

    Joined:
    Mar 11, 2008
    #1
    hi there,

    1st time poster, Long time reader. Anyhoo, small web server question. It all works fine except for one thing. We have a 2wire modem router with adsl2 running on it. This feeds into a 10 port switch which feeds into an 8 port switch. My computer with the web server on it comes off the 2nd switch. When I go into the modem router and adjust the firewall settings to "dmz plus" mode for my computer everything is fine and the site can be viewed remotley. However realising that dmz was allowing all applications and very unsafe, I changed it so I made a new application in the router firewall settings called "apache" and opened ports 80 and 443 on my computer. Now no joy. can't view the site remotley. Can anyone thing of something obvious I have done wrong? If more info is required please let me know. Am running a MP with 10.4.10. Also if no ideas, would like to know just how dangerous is it to run in dmz mode. Does that just put my computer at risk or everyones on the network?. Am pretty confused. Any help would be magic.

    Thanks
    Makka
     
  2. Winterfell macrumors regular

    Joined:
    Apr 3, 2007
    Location:
    Tulsa, Oklahoma
    #2
    Have you enabled port-forwarding for port 80 on both routers? Might be a useless question, but it sounds like you did it on your computer only.
     
  3. makatak88 thread starter macrumors newbie

    Joined:
    Mar 11, 2008
    #3
    thnx for the reply. No I selected my computer in the firewall section of the router and then forwarded port 80 and 432. I thought this was all I had to do.
    makka
     

Share This Page