Web sharing not working (Forbidden error)

Discussion in 'Mac OS X Lion (10.7)' started by andymac2210, Nov 8, 2011.

  1. andymac2210 macrumors regular

    Joined:
    Jul 18, 2011
    #1
    I posted this on the apple support forums a few days ago, but so far no help whatsoever from anyone there.

    So I thought I'd try mac rumours, since people here tend to be more helpful :D

    Basically web sharing isn't working (which is quite annoying being that I need to test sites I make on mobile devices without uploading to a server).
    Trying to host locally with web sharing doesn't want to work, it USED to work fine.
    Lion 10.7.2.


    http://localhost/~myusername doesnt work with web sharing turned on.
    http://192.168.0.102/ (my local IP on the network) also fails to work.

    It won't open locally or from other computers on the network.

    I tried the apple fix here http://support.apple.com/kb/TA25038

    Doesn't help.


    The exact error I get is
    Forbidden

    You don't have permission to access /index.html on this server.
    Apache/2.2.20 (Unix) DAV/2 Server at 192.168.0.102 Port 80
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Do you have a Sites folder in your home folder.

    I noticed that with Lion, (doing a clean install) I had no Sites folder which is the default home folder for the web service to use
     
  3. andymac2210, Nov 8, 2011
    Last edited: Nov 8, 2011

    andymac2210 thread starter macrumors regular

    Joined:
    Jul 18, 2011
    #3
    Yeah, you can 'create' a sites folder directly from the web sharing bit of the sys prefs.
    It automatically dumps that template from iweb in there.

    For some reason I can access that, but as soon as I strip it out and put my own site in there I get the same error as above.


    EDIT- oh and the 'sites' folder is the default 'personal website folder', as opposed to the 'computer' website folder located at Library/webserver/documents.

    (Neither works with anything other than the default iweb template, but both work with that, what the heck?)
     

Share This Page