Web sharing not working

Discussion in 'macOS' started by jmmo20, Nov 17, 2007.

  1. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #1
    Hello,

    A few weeks ago when I did a clean install of 10.5.0 I found that web sharing wasn't working at all. Whenever I tried to access localhost/~myaccount apache returned a Forbidden access error message.

    I was suggested to create a myaccount.conf file in /etc/apache2/users/ .. I did and nothing happened, the problem persisted.

    Now with 10.5.1 I expected this to be fixed, but that didn't happen either. Instead I tried to create a new user account in my computer and then found, to my astonishment, that web sharing worked. I even compared the user.conf file for that account with my user.conf and the only difference was the directory of course (/Users/useraccount***/Sites) .. all other arguments were the same.

    So.. I have no idea what is going on here!! I wouldn't want to go through the hassle of creating a new user account and migrate all my settings to the new one...
     
  2. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #2
    Does apache have read access to your site folder? (What are the permissions to the folder set as?)
     
  3. jmmo20 thread starter macrumors 65816

    Joined:
    Jun 15, 2006
    #3
    I compared the access permissions of my Site's folder with the Site's flder of the test user I created (where Web sharing did work) and the permissions are the same:

    Unix permissions: read for all (user+group+others)
    ACL permissions:
    owner r+w
    group (staff) r only
    others r only
     
  4. JonD25 macrumors 6502

    Joined:
    Feb 9, 2006
  5. jmmo20 thread starter macrumors 65816

    Joined:
    Jun 15, 2006
    #5

Share This Page