Web Site Notifications Not Working

Discussion in 'OS X Yosemite (10.10)' started by arftech, Oct 17, 2014.

  1. arftech macrumors regular

    arftech

    Joined:
    Aug 17, 2010
    #1
    Before the installation of Yosemite, I was able to get notifications from various web sites. Is there something that has to be toggled on my end or is it bug related?

    Thanks,
     
  2. cosminsel macrumors member

    cosminsel

    Joined:
    Oct 8, 2014
    Location:
    Ontario, Canada
    #2
    Do you have "Allow websites to ask for permission to send push notifications" enabled under Safari > Preferences > Notifications?
     
  3. arftech thread starter macrumors regular

    arftech

    Joined:
    Aug 17, 2010
    #3

    Yes, I do and they're also set for allow.
     
  4. cosminsel macrumors member

    cosminsel

    Joined:
    Oct 8, 2014
    Location:
    Ontario, Canada
    #4
    Maybe try removing the websites from the notifications list and visiting them again to reenable.
     
  5. arftech thread starter macrumors regular

    arftech

    Joined:
    Aug 17, 2010
    #5
    I wanted to log back in and give you props for the help. Yep, that was the solution and I feel like an idiot wrapped in a moron not figuring this out!:eek:
     
  6. cosminsel macrumors member

    cosminsel

    Joined:
    Oct 8, 2014
    Location:
    Ontario, Canada
    #6
    No worries. Glad I could help!
     
  7. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #7
    I've done this multiple times, and each time the alerts seem to only work for a day or so and then they break again!

    -Kevin
     
  8. dumastudetto macrumors 68020

    Joined:
    Aug 28, 2013
    #8
    I'm also experiencing this. Constantly removing and reactivating them on a site-by-site basis.
     
  9. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #9
    This looks to be a larger problem in Notification center in Yosemite. If you make any changes to apps in Notification Center, such as switch an app from Banner to Alerts.....and you restart or logout/in, the prefs you just set are discarded. I think this is causing issues with the website notifications as well.

    -Kevin
     
  10. bahamas1 macrumors newbie

    bahamas1

    Joined:
    Oct 18, 2014
    #10
    I found this on Discussions Apple and it worked for me:

     
  11. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #11
    Looks like it worked! Thanks for posting.

    Wonder how they'll handle this in the next update, since this basically resets everyones Notification Prefs.
    EDIT: Nevermind....looks like Yosemite wiped all my previous settings anyway ;-)

    -Kevin
     

Share This Page