Web surfing problem

Discussion in 'Mac Basics and Help' started by happy2gomac, Sep 20, 2010.

  1. happy2gomac macrumors newbie

    Joined:
    Aug 13, 2010
    #1
    Hi all,

    Brand new to macbook pro owner here. MBP i7 17" is what I'm using. When I surf the web using either Chrome or Safari, when I click on the track pad to go back, click a link or even try to scroll down on a page, I get the a down menu offering to go back etc. I can't simply "click" things and go. It happens ALL of the time. And to be honest, it's irritating as hell!! I've never had this issue with a windows based machine. Does it matter "where" I click on the track pad? Sometimes I'll have to click 2-3 times in an empty space to make the drop down menu go away. I will look up what all the drop down menu says. I was just sooo frustrated tonight I had to post. It's making surfing the internet on this nice new MBP a disaster!! Thanks for any input!! Also, many times I can't "arrow down" a page. The arrows just don't work. ARGH!!!!
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    It sounds like you may have two of your fingers touching the track pad when you click. That tells the computer you are trying to "right click" and gives you the box. Just make sure you use one finger to click, and stay away from the bottom right corner if that is set up for secondary click. You can also scroll up and down by using two fingers and moving up or down.
     
  3. lbro macrumors 6502a

    lbro

    Joined:
    Jan 22, 2009
    #3
    Try clicking with only one finger, two fingers means right click on OSX. Try scrolling using the two finger swipe up or down.

    EDIT:What alust2013 said.
     
  4. happy2gomac thread starter macrumors newbie

    Joined:
    Aug 13, 2010
    #4
    OK, thanks for the two finger heads up on scrolling down. That works perfectly!! However when I click a link, I still A LOT of times get a pulll down menu for open link in new tab etc etc. It's still very frustrating. Happens about 50% of the time I click on a link. I'm only using one finger when I'm clicking on a link. Any suggestions? It's driving me crazy!! Thanks for your patience!!
     

Share This Page