Webcam doesn't work on new cMP's USB 2 ports, only on USB 3 card

Discussion in 'Mac Pro' started by scott.n, Feb 14, 2016.

  1. scott.n macrumors 6502

    Joined:
    Dec 17, 2010
    #1
    I purchased a new (to me) 2009 Mac Pro recently. Yesterday I upgraded the processors and moved all of the drives and PCIe cards from my previous machine (also a 2009 dual-proc), reassembled my workspace, etc, but I've run into a problem with my Logitech C920 webcam.

    With my old machine, the webcam worked just fine plugged into my USB 2 hub (Satechi UH-12P). But with the new machine, the camera's image freezes whenever it is first activated (such as opening FaceTime app or starting a new video recording in QuickTime). This occurs whether or not the hub is powered from its AC adapter or just running on USB power from the Mac Pro (which is how I usually use it; the only other things plugged into the hub are my mouse and keyboard). Despite the frozen images the webcam appears under 'Camera' and 'USB' in System Profiler with seemingly correct information.

    To troubleshoot, I've plugged the webcam directly into the Mac Pro's USB ports (front and back) but there it isn't recognized at all. (I get the "No camera available. To use FaceTime, connect a camera." error message.) The webcam is not shown under 'Camera' or 'USB' in System Profiler.

    However, when I plug the webcam into my USB 3 card (Inateck KT4004 "4 Ports for Mac Pro" version) it works just fine! In System Profiler it appears correctly in 'Camera' and 'USB' sections.

    I've checked the Mac Pro's USB ports by plugging in thumb drives, which are all recognized. I've rebooted and also tested under a new user account; the issues persist. I've plugged the webcam into my MacBook Air (with USB 3; running 10.11.3) and MacBook Pro (with USB 2; running 10.10.5); in both cases it works correctly.

    On my new Mac Pro I'm running 10.11.3 on the same boot drive (SM951 / Lycom DT-120 card) that I was using in my previous machine.

    Does anyone have any ideas on what the problem might be?
     
  2. DearthnVader macrumors regular

    DearthnVader

    Joined:
    Dec 17, 2015
    Location:
    Red Springs, NC
    #2
    Could be a conflict between your USB Hub and the Web Cam.
     
  3. scott.n thread starter macrumors 6502

    Joined:
    Dec 17, 2010
    #3
    Thanks very much for the suggestion, but unplugging the hub and plugging the webcam directly into a USB 2 port on the Mac Pro, I still get the "No camera connected" error. Very frustrating.
     

Share This Page