WebDAV Apache2 Syntax Error

Discussion in 'Mac OS X Server, Xserve, and Networking' started by iBlink, Jan 22, 2013.

  1. iBlink macrumors newbie

    Apr 12, 2003
    Lion Server 10.7.5 Mac Mini

    After trying every "solution" I could find on the internet to get WebDAV working, I finally came across a post that fixed it...kind of.


    This post points out that the /etc/apache2/httpd_webdavsharing_sharepoints.conf file, which is autogenerated by the WebDAV process has a syntax error. This was confirmed in my system.log, which stated there was a syntax error on line 18.

    There were " " missing around the RewriteRule entry. As soon as I added the quotes and saved the file I was able to use WebDAV from the connect to server option on my mac (https://mydomain.com/webdav). Awesome.

    Here is my problem. As soon as the File Sharing service is turned off and on, it either rewrites the file or deletes my changes to the file and makes logging into the server with WebDAV fail at login again. It prompts me for credentials and then says there was a problem connecting to the server. rebooting the server keeps my changes, it just removes them when bouncing the File Sharing service.

    I need to know how to make these changes stick or if the file is being recreated, how do I tell Apache2 to add the quotes?

    I have also ditched the file and allowed it to recreate and the same error is present.

Share This Page