WebKit and I broke my iBook(sort of)

Discussion in 'PowerPC Macs' started by RedCroissant, Jun 24, 2013.

  1. RedCroissant Suspended

    Joined:
    Aug 13, 2011
    #1
    I was getting my 14" iBook set up and when installing Leopard Webkit again, this time I decided to install it and make it the default system browser via the included shell script as well as enabling advanced features with that included shell script.

    The Readme file warns that this could negatively impact system apps that rely on the default being Safari to work properly.....and well Safari, and Mail are no longer launching. These are the error messages I'm getting:

    For Mail:

    Dyld Error Message:
    Library not loaded: /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
    Referenced from: /Applications/Mail.app/Contents/MacOS/Mail
    Reason: image not found

    For Safari:

    Dyld Error Message:
    Library not loaded: /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
    Referenced from: /Applications/Safari.app/Contents/MacOS/Safari
    Reason: image not found

    Any advice or help would be greatly appreciated!
     
  2. skateny macrumors 6502

    skateny

    Joined:
    Jul 19, 2012
    Location:
    New York, NY
    #2
    Hey RC.

    I feel your pain. Hated it the few times my iBook started acting all squirrelly.

    Sorry I don't know how to reverse this process or repair what's been done because I never installed it system-wide. I do know that on more than one thread here people strongly suggested that you don't do what you did.

    Maybe if you search this forum you'll find a helpful response?
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    My only suggestion would be to download the combo update for 10.5.8, use Pacifist to open the package and navigate to the directory that is mentioned in the error. Copy whatever you find in that directory to your desktop (use a new folder on your desktop if there are a lot of files or other folders). Once Pacifist has everything unarchived, copy them to the same folder on your hard drive.

    You may want to back up that folder first.

    Anyway, overwrite if you have to then repair permissions. If necessary, restart.

    Now try opening the programs.

    The programs are looking for an image (based on the errors you posted) and can't find it. What I am suggesting will revert that particular folder back to stock.

    Do this at your own risk.
     
  4. B-G macrumors regular

    Joined:
    Dec 14, 2011
    #4
    Have you tried the uninstall script in the .dmg file?

    What version of Leopard Webkit did you install on your system?
    Only Series 536 is stable when installed.
     
  5. SawyerTHEBEST macrumors member

    SawyerTHEBEST

    Joined:
    Feb 5, 2013
    #5
    never hurts to have a clean os install ^_^ google drive is a good backup solution
     
  6. G4TheWin macrumors member

    Joined:
    Dec 8, 2012
    Location:
    A ditch somewhere
    #6
    This. Installing Webkit on my system just screwed it up.
     
  7. RedCroissant thread starter Suspended

    Joined:
    Aug 13, 2011
    #7
    I tried this and it did not work. The applications still did not open and were actually not limited to those three that I mentioned.

    I did try the uninstall script and it did nothing at all. I installed 5.0.7(I think). I'll look for the most update done then but I don't think I'll be installing it system-wide

    This is actually what I ended up doing. Lucky for me that I have a 12" iBook and a backup of everything on an external HDD.
     

Share This Page