WebKit.framework Corrupts Xcode Project

Discussion in 'Mac Programming' started by KillCodyDead, Jun 5, 2008.

  1. KillCodyDead macrumors newbie

    Jun 4, 2008
    I'm creating a very basic browser for quick personal use. I already know how to make the browser, but I'm having a little trouble with WebKit.framework. I know how to import the framework folder, but every time I do, I get this error on Build and Go:

    [Session started at 2008-06-05 02:20:20 -0500.]
    ZeroLink: unknown symbol '_NSApplicationMain'
    XBrowser has exited due to signal 6 (SIGABRT).
    I know for a fact that this has something to do with WebKit.framework, because I can make the entire browser EXACTLY the same without importing WebKit and I don't get that error. Obviously I can't use the browser without WebKit, so this is a pretty substantial problem. Also, if I delete the WebKit.framework after it has already been imported, I still get the error on Build and Go. So it appears that my Xcode project is corrupted beyond repair as soon as I import the framework.

    Any help would be greatly appreciated!
  2. SthrnCmfrtr macrumors 6502

    Aug 20, 2007
    Las Vegas, NV
  3. KillCodyDead thread starter macrumors newbie

    Jun 4, 2008
    Sorry, I'm very new at this, so this may be a bit of a newbie question, but how would I disable ZeroLink?
  4. KillCodyDead thread starter macrumors newbie

    Jun 4, 2008
    Fixed it. The problem was that my Framework Search path (under my target's info panel) was set to the 10.3.9 SDKs instead of the 10.4.11 SDKs.

Share This Page