Webkit Plugin Agent issues

Discussion in 'macOS' started by Hayduke60, Sep 11, 2009.

  1. Hayduke60 macrumors regular

    Joined:
    Mar 2, 2009
    #1
    My Plugin Agent keeps calling the debugger. Like, once a minute for the last 5 hours. I've searched and come up with nothing. I've repaired permissions from the terminal (sudo diskutil repair permissions / ) I reset my pram, I've reset Safari, I've downloaded the latest version of Flash, I've removed a bunch of programs. But to no avail. Hell, I even ran iantivirus and found nothing.

    Is there something else I could try? Other than removing Console.....
     
  2. broken-chaos macrumors regular

    broken-chaos

    Joined:
    Sep 2, 2009
    Location:
    Toronto, Ontario
    #2
    What do you mean by "Calling the debugger"?

    Do you mean crashing and asking you to report it to Apple?
     
  3. Hayduke60 thread starter macrumors regular

    Joined:
    Mar 2, 2009
    #3
    In my console, it tells me that.. webkit Plugin Agent229 Debugger() was called!


    No crashes so far but things have slowed down.
     
  4. broken-chaos macrumors regular

    broken-chaos

    Joined:
    Sep 2, 2009
    Location:
    Toronto, Ontario
    #4
    Getting rid of Console.app would not change this issue at all then... I'm not sure why it would be occurring, but Console just records/displays messages from other applications, it doesn't generate them.
     
  5. Hayduke60 thread starter macrumors regular

    Joined:
    Mar 2, 2009
    #5
    No I wont remove my Console, that's just frustration talking. I'm thinking his may have something to do with my quicktime player or Quartz. I'm gonna go with quicktime first and see what happens.
     
  6. Catfish_Man macrumors 68030

    Catfish_Man

    Joined:
    Sep 13, 2001
    Location:
    Portland, OR
    #6
    It's Flash, and it's harmless. Unfortunately it's also impossible to do anything about if you use Flash.
     
  7. Hayduke60 thread starter macrumors regular

    Joined:
    Mar 2, 2009
    #7
    Thanks guys. I read elsewhere that it was Flash but the latest version didn't help. If it's harmless then it can go on calling the debugger all it wants.
     
  8. broken-chaos macrumors regular

    broken-chaos

    Joined:
    Sep 2, 2009
    Location:
    Toronto, Ontario
    #8
    If it (or the Flash slowdown) is annoying you in situations you don't need Flash in, I'd recommend looking at ClickToFlash.
     
  9. Hayduke60 thread starter macrumors regular

    Joined:
    Mar 2, 2009
    #9
    Thank you, I just downloaded it and will see how it works and report back.
     
  10. Hayduke60 thread starter macrumors regular

    Joined:
    Mar 2, 2009
    #10
    Nope, the debugger is still being called. I just let it do what it does.....
     

Share This Page