WebView crashes on www.apple.com

Discussion in 'iOS Programming' started by cokeaholic, Oct 16, 2008.

  1. cokeaholic macrumors newbie

    Joined:
    Jun 17, 2006
    #1
    I can't believe it either but when I load the web site www.apple.com into an UIWebView, the page loads but then suddently turns into a grey blank page.

    The problem is that my app is under review and Apple is testing it with their own website. It got rejected because of that problem.

    I am now desperately looking for someone to confirm this behavior.
    Please help ...
     
  2. wizard macrumors 68040

    Joined:
    May 29, 2003
    #2
    Strange!

    Hi

    I'm far from an iPhone expert but there are a few that show up here from time to time. To help us out you could post some code as frankly we would be guessing at what your problem is otherwise.

    Not to discourage you but on my stock iPhone 3G Safari is the least stable app by far. I have more than a few third party apps installed and none of them fail in the way Safari does.


    Dave
     
  3. cokeaholic thread starter macrumors newbie

    Joined:
    Jun 17, 2006
    #3
    Hi, I checked it again, this time with official sample code from Apple.
    It's definitely a bug in the UIWebView component.

    You can try it yourself:
    - Load the "UICatalog" sample project from the Apple Dev page and run it
    - Click on "Web"

    It will automatically try to load "www.apple.com" and before it finishes loading, the page goes blank.

    I hope this will be fixed soon.
     
  4. hollywoodDev2 macrumors newbie

    Joined:
    Oct 24, 2008
    #4
    UIWebView "bug"? in UICatalog sample app...

    Hey, I've noticed this issue with the "grey" screen appearing after the "apple.com" url loads too!!! ...Anyone know why its doing this? Im using their code as a foundation for mine, and Im afraid I'll experience the same unwanted behavior. Anyone???
     
  5. TyloBedo macrumors member

    Joined:
    Aug 7, 2008
    #5
    yah ironically safari crashes on my iphone whenever i load to page after i click "buy know" under the macbooks >_>
     

Share This Page