Weird airport problem

Discussion in 'MacBook Pro' started by Greg90, Jul 17, 2008.

  1. Greg90 macrumors newbie

    Joined:
    Jul 13, 2008
    #1
    Just bought a new MBP, and I'm having some problem with airport. It connects fine, but I get kicked off like every 3 minutes from my network. The issue isn't with my modem/router as my windows laptop, imac and ipod touch all work fine with it.

    ANy ideas what's wrong?
     
  2. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #2
    This is a very common problem. Do you have a Wireless N router? If you do, change your router to Wireless B and G only. Some older wireless N routers have some problems with true wireless N like in the MBP. What router do you have?
     
  3. dv3 macrumors newbie

    Joined:
    Jun 17, 2008
    #3
    i'm having the same problem...i've had a dlink g router and was fine...upgraded to a APEBS and enjoyed the faster connection about a month ago...now yesterday my MBP just started disconnecting...everytime i want to click a link i have to disconnect and reconnect... I would a assume the APEBS would be compatible with my MBP...
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    Is it saying you're having duplicate IPs? If it is, I fixed mine by resetting the router.
     
  5. dv3 macrumors newbie

    Joined:
    Jun 17, 2008
    #5
    i dont believe its a duplicate ip problem...i've already reset the router twice and tried downgrading the firmware...the problem persits...i dont know why it's doing this
     

Share This Page