Weird Apostrophe Bug

Discussion in 'OS X Mountain Lion (10.8)' started by ObeseSquirrel, Feb 5, 2013.

  1. ObeseSquirrel macrumors regular

    Joined:
    Nov 22, 2011
    #1
    For the last couple of days, I have been having a really weird bug in Mountain Lion.

    When I hit the apostrophe key, the apostrophe is highlighted and then the very next letter I typed becomes a different variant of that letter. (The same variant that would be "1" if I had held the key down.)

    So "it's" now shows up as itš"...

    How do I fix this?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    That is not the apostrophe key then, but a diacritical mark. What physical and software keyboard layout do you have?
     
  3. ObeseSquirrel thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #3
    I fixed the problem. My keyboard layout had been hidden from my dashboard, and after playing with the 'Language & Text' requirements for a while (I don't think I reenabled the Menubar icon) the flag reappeared. My settings had somehow been changed to Polish. I switched back to the American keyboard and it was fixed.

    This behavior had only started today, and I have not been playing with my keyboard settings recently. Idk, 10.8.2 has been real buggy for me. Hopefully 10.8.3 will fix these problems...

    Thanks, btw.
     
  4. ObeseSquirrel, Feb 6, 2013
    Last edited: Feb 6, 2013

    ObeseSquirrel thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #4
    WTF! The keyboard settings changed by themselves again. It switched to Latvian! (It was actually Latvian both times.)

    Is there anything I can look for in the Console for this? I'm a little worried I might have been hacked.

    EDIT: I have Cmd-Spacebar set for Spotlight and Ctrl-Spacebar for switching keyboard layouts. Maybe I am hitting the wrong key by accident? This has only started recently though...
     

Share This Page