Weird Artifacts Sometimes When Gaming.

Discussion in 'MacBook Pro' started by BrickbookPro, Aug 10, 2011.

  1. BrickbookPro macrumors regular

    Joined:
    Jul 26, 2011
    #1
    So I've recently started playing CoD 4 and as of today after about 20 minutes of play I get these pixelated artifacts in spots on the screen (both the laptop monitor and the external monitor).Is it the game or the computer? They weren't there before. See picture below:

    BTW, It's a macbook pro. THANKS!
    [​IMG]
     
  2. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #2
    Across both monitors on the same spot?
    Then it's most likely the game.
     
  3. BrickbookPro thread starter macrumors regular

    Joined:
    Jul 26, 2011
    #3
    Yes, both monitors same location. You don't think the GPU is over heating? I just used fn+f1 to get the same thing displayed on my laptop monitor and external 1600X900.
     
  4. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #4
  5. BrickbookPro thread starter macrumors regular

    Joined:
    Jul 26, 2011
    #5
  6. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #6
    Looking at the photo again, I can tell you which file has been corrupted.
    It's the game file for your crosshairs! I can't believe I didn't notice that! All you need to do is fix that and you won't see it anymore. :D
     
  7. JDNGuru macrumors member

    Joined:
    Sep 4, 2010
    #7
    I get that too, when I play WoW. Sometimes the characters or items turn pitch white in the game. Lol.
     
  8. BrickbookPro thread starter macrumors regular

    Joined:
    Jul 26, 2011
    #8
    Did you see the artifacts in the bottom left and right as well? Also on the player where the arm is black?

    I guess I'm still a little concerned because sometimes it does it and sometimes it doesn't. When it does, it slowly gets worse until I close out of the game.

    Thanks for the help!
     
  9. Kafka macrumors 6502

    Joined:
    Mar 10, 2011
    #9
    Happened to me too (not playing anymore). That's an issue with the HD3000, like if there was sometimes a short delay before the textures are applied.

    Maybe driver related? Never happened on my 2010 MBA.
     
  10. Adamantoise macrumors 6502a

    Joined:
    Aug 1, 2011
    #10
    I think it's because you're playing a terrible game, maybe if you play a better game like Battlefield the artifacts will go away.
     
  11. erictooth macrumors newbie

    Joined:
    May 20, 2010
    #11
    <3
     
  12. BrickbookPro thread starter macrumors regular

    Joined:
    Jul 26, 2011
    #12
    Haha I used to play battlefield 1942. Not sure about current versions, but CoD 4 definitely beats that. Besides I don't have a windows environment to run games so i can't run mother games. Also, I got CoD4 from my brother free of charge :)


    So is the consensus that my card (320m in 2010 MBP 13") is fine and that it is software related?
     

Share This Page