Weird Audio problem with jack and speakers

Discussion in 'MacBook' started by The Stig, May 19, 2008.

  1. The Stig macrumors 6502a

    The Stig

    Joined:
    Nov 4, 2006
    Location:
    On the track
    #1
    A friend of mine as a newer (gen before the current one) Macbook and he has a very weird problem...

    When he starts playing any audio, lets say from itunes, it starts to play but there is NO AUDIO what so ever. No sound will come from his speakers at all. So he plugs in headphones and they work fine, and then unplug his headphones and then the speakers work fine....

    So the only way he can get something to come out of his speakers is to plug and unplug something in his headphone jack and then it works fine.

    I believe it just started happening after he took it to an Apple store and they replaced his HD. So he'd have a fresh install of 10.5. I know that replacing the HD wouldn't have anything to do with it. So I'm lost for ideas.

    Anybody have this problem before?

    The Stig
     
  2. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #2
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419.3)

    When does it start doing this? After he reboots, after waking it from sleep, etc.

    Tell him to double check the sound preferences inside system preferences to make sure everything is set correctly if he hasn't already done so.

    It may happen if he is listening to music through the head phones then closes the computer with the head phones still pluged in. After that he unplugs the head phones. Next time he wakes it from sleep the computer still thinks the head phones are plugged in so it pipes the sound to the head phone jack. This may be what is causing it.

    Hope this helps.
     
  3. atad1234 macrumors newbie

    Joined:
    Jun 30, 2008
    #3
    similar problem - I am confused

    hey. I have a similar problem.
    I don't normaly use headphones but I have external speakers pluged 24hour to my macbook which also always on, just screensaver and shuted displays, never sleep.
    every time I leave it for a while and comes back, there is no sound coming from the speakes. the preferences are fine, also when there is no sound coming out nothing is strange in ne "sound preferences".
    I have to play a few seconds with the volume keys to get the sound back.
    Some times it happen few times in a day. sometimes evan while a song is playing in itunes.
    I suspect it has something to do with my new WD passport external HDD, because it takes electricity from the USB port and the problem is about as new as the HDD, not sure about that.

    I tryed it all nothing works. any suggestions?

    macbook 2.16ghz OsX leopard 10.5.3 ( 2*512ram )
     
  4. cavtma macrumors newbie

    Joined:
    May 24, 2008
    #4
    same problem


    I have a 2004 PowerBook G4 and experience the same problem from time to time. Actually, the problem is so great that I can't really listen to anything longer than 5 minutes on the external speakers before they "go dark". And this isn't after extended headphone use, or exterior speaker use. It's just something random that started happening a year or so ago and has not worked properly since.
     

Share This Page