Weird Bug: OS X Fails to Write to Disk after Wake from Sleep

Discussion in 'OS X Mountain Lion (10.8)' started by ObeseSquirrel, Nov 23, 2012.

  1. ObeseSquirrel macrumors regular

    Joined:
    Nov 22, 2011
    #1
    This bug seems to occur after waking from sleep, especially when after I have moved to a different wifi network. (I am not sure whether this is the cause of the problem.) It has only happened since upgrading to 10.8.2, and I believe it started after the 12C60 supplemental update.

    This has happened 4 times. The symptoms are slightly different each time, but generally my computer loses the ability to write to the disk (meaning that I cannot save my files) and new apps fail to open. (They just keep bouncing in the dock.)

    One time when this happened, I also lost access to my keychain, and the system kept asking for my passwords, which I would not give. Another time, some of my apps began to close randomly, before failing to reopen.

    This problem seems to be solved by rebooting and resetting PRAM, though I am not completely sure about this. At least one time when I rebooted without resetting PRAM, the problem started again, but then worked properly after a PRAM reset.

    Disk Utility does not find any disk errors or permissions problems following these incidences. I reinstalled the Combo update for 10.8.2 after one incident (the second time this happened) but the bug reappeared after several weeks. Sometimes my Spotlight will start reindexing after I fix the problem. Sometimes it doesn't. Because the machine cannot write to the disk, I do not think there is an error log for it.

    This problem has become even more persistent over the last couple of weeks.

    (mid-2010 13" Macbook Pro, 8 GB Crucial RAM, Corsair Performance Pro SSD)

    Additional details:
    -I am using TRIM Enabler
    -SSD is set to Wake for Network Access (when plugged in)
    -"Put hard disk to sleep when possible" is left unchecked.
     
  2. levous macrumors newbie

    Joined:
    Oct 8, 2008
    #2
    I'm having the same issue after replacing my superdrive with a hard drive and then installing the OS on a SSD in the original HDD location. I'm using the Optibay conversion. It works great until the computer hibernates and then I need to reboot.

    If I find the solution, I'll post back but if anyone has any idea, love to hear it.
     

Share This Page