Weird Bug

Discussion in 'macOS' started by dpaanlka, Apr 4, 2007.

  1. dpaanlka macrumors 601

    dpaanlka

    Joined:
    Nov 16, 2004
    Location:
    Illinois
    #1
    On my Mac Pro, I have my normal account and a guest account setup for friends who come in my room that may want to use my computer. My screen saver is set up to automatically come on after ten minutes, and it is password protected, but if somebody wants to use my computer they can click "Switch User" as I have fast user switching enabled.

    Anyway when they click this, the screen goes all crazy for a moment as the Quartz Extreme cube action happens, then it goes back to normal.

    This does this with every screen saver I have tried.

    Is there a reason it does this? Does it do this for anybody else?
     
  2. lancestraz macrumors 6502a

    lancestraz

    Joined:
    Nov 27, 2005
    Location:
    RI
    #2
    I have a iMac G5 that did the same thing. Apparently it had a faulty logic board. Got it replaced and the problem is gone.
    Now, I kinda doubt this is what is wrong with your Mac Pro; thought I would throw it out there anyway...
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  4. dpaanlka thread starter macrumors 601

    dpaanlka

    Joined:
    Nov 16, 2004
    Location:
    Illinois
    #4
    All sorts of random colors and lines and artifacts just appear out of nowhere and fill the entire screen.
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    Hmm... this sounds like a Quartz Extreme bug. Do you have the preliminary support for Quartz 2D Extreme enabled in Quartz Debug? If you do, disable it.
     

Share This Page