weird character display on websites

Discussion in 'Mac Basics and Help' started by quiet dear, Jul 7, 2008.

  1. quiet dear macrumors newbie

    Joined:
    Jul 7, 2008
    #1
    Hi,
    Recently I have been having some trouble with some websites displaying type strangely. It is only some websites here and there and a few weeks ago they were displaying fine.

    [​IMG]

    Here is what it looks like.

    I've run fontbook and gotten rid of all duplicate fonts, and that didn't help. Upon going to the apple store, they told me to run an archive & install, which I did tonight and that hasn't helped either. When I run font validation in fontbook, it tells me that everything is running smoothly. Does anyone have any idea what would be going on?
    I am using Firefox 3, but the same thing happens in Safari. This only happens on the web, and never in any applications.

    Thanks! :(
     
  2. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #2
    Archive and install won't help since it saves your preferences ...

    Though I would have thought the Font Cache got purged, maybe not.

    Might run the remove font cache scripts for Leopard.
     
  3. quiet dear thread starter macrumors newbie

    Joined:
    Jul 7, 2008
    #3
    I've just run a program that removes the font caches (FontNuke) and I've still got issues with the font displaying correctly.

    I've tried changing the default font in Firefox from Times to Arial... the serifs come and go but the weird characters and subscripts still stay the same.
     
  4. souta macrumors newbie

    Joined:
    Feb 26, 2007
    Location:
    los angeles
    #4
    I have the same font problem with some websites using firefox and safari. I discovered that if uncheck the box in preferences that allows the website to use its fonts, the issue is resolved. But that is no solution, really. I like viewing websites using their fonts. I'm sure there is a solution to this annoying little problem, and I'm a little surprised that others who are more technically advanced have not helped us out here.

    souta
     

Share This Page