Weird Charging Problem

Discussion in 'MacBook Air' started by lilkangster, Dec 15, 2011.

  1. lilkangster macrumors member

    Apr 17, 2011
    Recently My MBAir has this weird problem where it would just stop working after a while. Fiddling around with the connector or the plug does not fix the problem however if I just leave it sitting there over night it would start working again. Not sure if anyone else has had this problem. Do you guys think this is a problem with the MBAir itself or is it the charger thats defective? took it in to the genius bar but I couldn't reproduce the problem when I took it in. They ran some diagnostics and say nothings wrong but it happened twice again after. Anyways any insight into this issue would be appriciated.
  2. redpinecone macrumors newbie

    Dec 15, 2011
    Same here

    This has been happening to my 2011 13" MBA for a few weeks now. Sometimes when the power is connected, no led's light and it will not charge. When in this state, other chargers will not charge the MBA and my charger will work with other machines. So, it's not my adapter, but the MBA.

    I have been to the genius bar 3 times, 2x they could reproduce it. As I understand, they determined the sleep image was corrupted somehow and confusing the power controller so that it did not know when an adapter was connected. Deleting the sleep image & lots of restarting made it work again.

    The third time (a couple days ago) they re installed the OS. They are convinced that it is a software problem and not hardware. When I ask if they see this on other machines, they won't answer directly. But they seem to know just what to look for.

    So, I am now waiting to see if the issue resurfaces after the OS change.

    Good to know I am not the only one...
  3. JoeShlabotnick macrumors newbie

    Dec 5, 2011
    line noise?

    My daughter had a similar problem with her MacBook Pro - turns out the charger was shutting off periodically due to noise in the AC supply. Turns out it was her hair straightener causing the line noise!

    See this Apple KB article, specifically under the heading "Identify line noise issues", for a quick way to check if this is your issue:
  4. redpinecone macrumors newbie

    Dec 15, 2011
    When my machine is misbehaving, it does it everywhere. My home, my office, a hotel in a different city.

    Anyone else seeing this behavior?
  5. lilkangster thread starter macrumors member

    Apr 17, 2011
    Yup I seem to have the exact same problem. After what you mentioned I actually switched chargers with my MBPro and it does not charge also. So yea I am now sure that it is definitely a problem with my air. What OS version are you running on your Air? I have a early 2011 model upgraded to OSX Lion 10.7.2 might be a software problem if we are both running same OS version.
  6. redpinecone macrumors newbie

    Dec 15, 2011

    My MBA was purchased in August, also running 10.7.2. I noticed this problem for the first time about a month ago.

    Anyone else experiencing this?
  7. Mlrollin91 macrumors G5


    Nov 20, 2008
    Ventura County
    Had this problem with my 2009 MBP. Apple had to replace logic board and MagSafe charger board, and the charger itself. Then the problem finally went away.
  8. redpinecone macrumors newbie

    Dec 15, 2011
    Well, it's happening again. I've got 9% battery left & this thing will be dead with no way to charge it. I'm a long way from home & from any Apple store.

    I'm not a very happy Apple customer right now.
  9. redpinecone, Jan 2, 2012
    Last edited: Jan 5, 2012

    redpinecone macrumors newbie

    Dec 15, 2011
    Follow up

    My MBA spent a week in for repairs. I had to be VERY insistent that this problem was real, because they initially could not get it to happen. They wanted to give me a new adapter & send me home. After running diagnostics over the next couple days, they said nothing was wrong & wanted me to pick it up. I was again VERY insistent that there was a real problem, and they agreed to look further.

    Finally got them to open it up & look around. The tech called me & said he was able to create the condition by applying pressure to the power connection to the module that includes the MagSafe and USB port on that side. He disconnected, cleaned, & re-seated the connector and could not make it happen afterwards. His theory was that it was never connected properly at the factory, or that repeated expansion & contraction from heat caused it to loosen.

    Only time will tell if this is truly fixed.
  10. morberg macrumors newbie

    Jan 4, 2012
    Registered here just to add that I have the exact same problem. Haven't tried deleting the sleep image, but will see if that helps.

    It is very random, it has been working for weeks without a glitch but now it is acting up again and not charging.
  11. morberg macrumors newbie

    Jan 4, 2012
    OK, I deleted the sleep image (issue 'sudo rm /private/var/vm/sleepimage' in a terminal window) and rebooted the machine with the non-charging charger plugged in the machine. Still not charging. Then I deleted the sleepimage again planning to do another reboot, but as soon as I deleted it the second time the charger led turned on.

    Thanks for the tip, I hope it keeps working this time. Sending the computer away for a repair that might not even fix anything would've been annoying.
  12. komoornik macrumors regular

    Jul 29, 2011
    What about SMC and PRAM/NVRAM reset?

    I had some problems with magsafe and it fixed it ( at least i think, coz it's not happening for few days ).
  13. mixman macrumors member

    Aug 3, 2011
    Having a charging problem also ( SMC reset doesn't help. The laptop is getting worse by the day; by now, it shuts down by itself if not plugged in to an adapter.

    Apple has a problem on their hands. I need to get mine to the repairs before all the other 2011 macbook air owners follow suit. :)
  14. onthecouchagain macrumors 604


    Mar 29, 2011
    I wonder if this has anything to do with my own recent problem: My Air was completely depleted of battery when I shut it off (not sleep) at around 50%. Two days later, I go to turn it on, and it wouldn't turn on. There was no power whatsoever in it. I had to plug in my charger and then it would turn on, and when it did, it said 0%.

    I haven't been able to reproduce the problem so far, though I've discovered the battery does drain slightly (by about 2 or 3%) even when shut down.

    Is this problem similar or related at all to this thread? I hope it's not a general 2011 Air related issue. Mine is the 13" base 2011 Air.

    Also: What's everyone's battery cycle count?
  15. englishman macrumors 6502a


    Nov 6, 2006
    Similar problem I thought I just had one that was very fussy about how snug the Magsafe connector lined up with the MBA indent.
  16. Consultant macrumors G5


    Jun 27, 2007
    Just about all your computers are under Apple warranty, so contact Apple for support:
  17. sjatkins macrumors newbie

    Mar 1, 2007
    I have this issue on my MBA. Never had the issue on the original 13 inch MBA. Have had it sporadically since I bought the 11 inch MBA. It has nothing to do with sleep as far as I can see. A fully awake MBA will occasionally exhibit the behavior when I plug in the power. Nor is it the mark of a "genius" to reinstall the OS and hope it goes away. On mine if I unplug and replug a few times switching the orientation of the plug it eventually decides that it is in fact charging and the light comes on. I am convinced it is a flaky connector as one post mentioned.
  18. Nisso macrumors newbie

    Sep 28, 2011
    Its probably the connection between you MB and your charger that is causing the problems. Can elaborate this with my own experience on this issue.

    Bought a MBP 15 uni, in late 2008, and have gone through 4 different chargers! Every single one has had the same problem, really unreliable connection. Sometimes it helpes to play around with different positions and applying pressure, but this only worked for a month or so until they all just stopped working. Somehow the chargers plug and/or the port on the MBP wears down, and connection is lost!

    Tried them on other peoples MBP, and they worked almost all the time.

    Also comfirmed this when i last week got a new Core i7 15", and every single one got fully or at least some connection. (they were all charging, but some were loosing connection quite easily).

    They are all "old" t-type magsafe, not the newer L-models which i havent had long enough to test.

    Hope this helps
  19. scupking macrumors 6502a

    Dec 14, 2010
    Interesting this just started happening yesterday with my 2010 13" MBP. I have it plugged in and it says not charging and the charge light is off. No matter what I do I can't get it to charge now.
  20. morberg macrumors newbie

    Jan 4, 2012
    I'm pretty sure the sleepimage had nothing to do with the problem, write this up as a fluke.

    I've hade the non-charging problem reappear many times since this and deleting the sleepimage has done nothing. It typically takes 2-36 hours for the charger to start working again, but I haven't found an action that brings it back to life.

    Called Apple for help and they referred me to my local Apple store. They want to bring the computer and charger in for trouble shooting which is kind of annoying since the problem only occurs once a week or so... Just give me a new power supply and that should be it.

    This is the most disappointed I have been with Apple support in a long time, I'll try a different store and see if they are easier to deal with.
  21. erpetao macrumors regular

    Jun 19, 2011
    I have the same problem. Unplugging it and plugging it agains seems to solve the issue (the light goes green and then orange).
  22. erpetao macrumors regular

    Jun 19, 2011
    Interesting.. I'm travelling with a mini-fridge that I plug while on hotel rooms, etc. Could it be causing this? From the Apple website:

  23. morberg macrumors newbie

    Jan 4, 2012
    I called Apple centrally and they sent out a new power supply a couple of days ago. Everything has been working perfectly since then.

Share This Page