Weird DirectX behavior on Fusion 2.0 and XP SP2

Discussion in 'Windows, Linux & Others on the Mac' started by procyonx86, Nov 29, 2008.

  1. procyonx86 macrumors member

    Nov 25, 2008
    Hi everyone,

    Uni MBP owner here. A few days ago I downloaded the trial version of Fusion 2.0 from the VMWare website, and proceeded to install XP SP2 on it. I turned on 3D acceleration, installed VMWare Tools on it, then installed SimCity 4.

    In the game, the graphics were so glicthed (on any res, on any setting -- I tried everything) I had to switch to the software renderer. I tried using the hardware renderer on the 9400 or the 9600: same screwed-up graphics. So I fired up dxdiag and ran the direct3d tests. Normally, you would see a smoothly spinning cube bearing the DX logo. I saw the cube, all right -- the problem was it was spinning so fast, it started becoming glitchy - exactly like the glitches I saw in SimCity 4.

    I dug up my old DX7 games to test whether even those were affected, and.. yep, same glitchy graphics. Even worse, some DX7 games (Deus Ex, UT) crashed whenever I tried to get my resolution higher than 640x480.

    Is this "normal" for Fusion 2? I thought they managed to get full DX9.0c support? Or is it just my comp? I honestly have no idea where I screwed up, and googling hasn't helped me much either.

    Can anyone please help?

Share This Page