Weird Dock problems

Discussion in 'MacBook Pro' started by Mars478, Sep 17, 2010.

  1. Mars478 macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #1
    My MacBook Pro is having some weird dock problems that started today. I recently installed a 64GB Patriot SSD and reinstalled the OS from scratch. I've tried repairing permissions but no luck.
    Here's a pic
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  3. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
  4. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #4
    Here is the picture
    I just booted my computer and while it was hibernating and it froze and it did colored like TV Static. it was insane, have pic of that too.
     

    Attached Files:

  5. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #5
    What is this?
    Could it be my SSD?
     

    Attached Files:

  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    I'm missing something. I see nothing wrong with your Dock. Can you be more specific?
     
  7. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #7
    Finder icon, Dashboard icon are missing, correct reflection of dock is not there.
    for comparison here's the dock from my imac.
     

    Attached Files:

  8. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #8
    Here's a better picture of the dock from my MBP (Trash icon also missing)
     

    Attached Files:

  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    If you just installed the OS, your Dock won't reflect the changes you made on your iMac's Dock. Also be sure you're logged in as the same user, with the same privileges. If you need to rebuild the Dock's plist, delete this file:

    /Users/~username~/Library/Preferences/com.apple.dock.plist
     
  10. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #10
    I solved the dock problem, took the functioning dock.app from my imac, put it on to my MacBook pro (deleted the old one via terminal)
    I still have some other problems... Now the icons in my ichat won't display. like the avatars. Damnit...
     
  11. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #11
    That wasn't the problem.
     
  12. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #12
    Glad you worked it out!
     
  13. Mars478 thread starter macrumors 6502a

    Mars478

    Joined:
    Mar 6, 2008
    Location:
    NYC, NY
    #13
    Pretty sure it's this SSD... Shouldn't have bought it from ebay.
     

Share This Page