Weird email problem with Mail application on 2G

Discussion in 'iPod touch' started by Mazda 3s, Oct 17, 2008.

  1. Mazda 3s macrumors 6502

    Mazda 3s

    Joined:
    Oct 29, 2006
    #1
    I recently got my 2G, but am having problems with one of my email accounts. I have a Gmail account and a work account -- both IMAP. The Gmail account works just fine, but my work account won't work properly. I never had an issue with either account on my 1G iPod touch -- only now with my new 2G. It will not sync the inbox of my work account at all. Strangely enough, however, it will sync the sent folder and every other folder on the mail server. This is truly puzzling.

    Now, I can use my mail account just fine with Outlook 2007 on my desktop and even with Thunderbird 2.0. I can even log into my work email from the webmail application using Firefox -- it's only the iPod touch that is freaking out. I've tried restoring two times to no avail. The Gmail and work email account settings are synced with my Outlook 2007 account via iTunes, so there is not a problem with the server settings. I even disabled email account sync in iTunes and entered the information manually on the iPod touch and it still won't work.

    Here's a picture of what's happening -- the iPod just gets stuck at "Downloading 1 of 100 messages". The spinning progress wheel at the top keeps going and the message never goes away.

    [​IMG]

    Here's a picture showing that sent folder syncs just fine:

    [​IMG]
     
  2. pismodude2 macrumors 6502a

    pismodude2

    Joined:
    Jan 22, 2008
    Location:
    MacWorld
    #2
    It just takes a REALLY long time the first time (but give it a break, it's downloading 100 messages!). Just leave it sit for a while (don't ask me how long, you'll know when it's done:D).
     

Share This Page