Weird errors with drive mounting and file copying

Discussion in 'Mac Basics and Help' started by EmptyG, Mar 27, 2007.

  1. EmptyG macrumors regular

    Feb 16, 2007
    Hello again all. So I posted a few days ago with an issue where some of my folders disappeared and could only be found via spotlight...

    Yesterday I was playing around on my MBP and something weird happened...

    When I opened finder, in the left hand column, I could see the usual "applications", "music" ,"movies" etc. Then I opened it again later and they were all gone :(

    I can search for files in spotlight and find them, but for some reason they don't show up in finder itself. And the shortcuts in the left hand column are gone too :(

    Is this something simple and I am just missing it? Again, I can find the files in spotlight, and it tells me they are in users/me/Movies - but when I navigate there, it's all empty. Also, some icons on my desktop that were there yesterday are gone today (like the icon for my backup hard drive, parallels icon, Boot camp partition, etc. The only thing there now is the icon for "Macintosh HD"

    Help! :( Thanks! ​

    So I rebooted and it fixed it. Theh yesterday, I plugged in my external HD (LaCie 320GB d2 drive) which normally works just fine. It would not mount and I could not get it to show up at all. I rebooted again, worked like a charm.

    Now the latest one. I tried copying some files from that external drive this morning onto my local hard drive. It would not let me copy them no matter what I tried. I have plenty of space on my local drive, so that was not the issue.

    I rebooted again, works just fine. But I am concerned here. I was told that a Mac can stay on (which mine does) and needs very few reboots overall (yes, I am a PC switcher - switched about 3 weeks ago).

    So what does this sound like? Bad hardware? Bad software? Mac OSX maybe? I've only had the thing for a little over 3 weeks and these issues are troubling me. The only things I have installed recently are Synergy (to share my keyboard and mouse from my PC), VLC, Mplayer.

    Thanks for any help in advance!!! :)
  2. Super Macho Man macrumors 6502a

    Super Macho Man

    Jul 24, 2006
    Hollywood, CA
    First of all - open up Disk Utility (in Applications/Utilities) and verify/repair both your internal and external drives. I'm guessing there is some corruption on one of the drives, but maybe not. Disk Utility kind of sucks in that it can't repair everything and can't detect all errors, but it's better than nothing.

    Next time this happens, press option+apple+esc, select Finder, and click Relaunch. If that solves the problem, then it's a problem with the Finder.

    Also, you say "it would not let me copy them"... was there any error message? Next time you can't copy anything, open up Terminal, and try to copy from the command line. That will bypass the Finder which will pinpoint the Finder as the problem if it works, and give you an error message if not which will be useful for troubleshooting. Try to copy something both TO your external drive:

    cp /Users/yourusername/Desktop/some_file_on_my_desktop /Volumes/name_of_my_lacie_drive

    and FROM your external drive:

    cp /Volumes/name_of_my_lacie_drive/some_file_on_the_drive /Users/yourusername/Desktop

    Good luck... oh yeah, if the Lacie drive's name has a space in it (like Lacie HD) it will have to be typed like "Lacie\ HD" on the command line.

Share This Page