Weird GDB Error

Discussion in 'Mac Programming' started by isthisonetaken, Dec 2, 2010.

  1. isthisonetaken macrumors regular

    Jun 29, 2006
    Hello All,

    so I got the strangest error the other day. I had a program that I made for a class, it uses the MCPKit.framework to access and interact with a MySQL database. Everything was great and I was ready to demo it for the prof and TA, but had to wait for 40 minutes until it was my turn. In that time I didn't do anything to the project (it worked before, I went through the demo with a friend). When they came to me, I built it and it succeeded, but when I clicked Run, it wouldn't load and had this error:
    WHERE THE APP IS STORED/Contents/MacOS/../Frameworks/MCPKit.framework/Versions/A/MCPKit' was not compiled with -fobjc-gc or -fobjc-gc-only, but the application requires GC
    objc[821]: *** GC capability of application and some libraries did not match
    Program received signal:  “EXC_BAD_INSTRUCTION”.
    sharedlibrary apply-load-rules all
    Data Formatters temporarily unavailable, will re-try after a 'continue'. (Not safe to call dlopen at this time.)
    I tried cleaning and rebuilding and running, same error. I was able to run the demo by changing the target to release mode and it was fine, but in debug I always get this error.

    It seems from the error that something went wrong with the MCPKit? I know the instructions for adding it had me add a New Copy Files Build Phase, set to frameworks and copied the MCPKit.framework into it. Something is clearly going wrong with that, but I don't understand why everything was fine, nothing was changed, and then crashed?

    I should also mention that I searched Google, but all I could find was a guy was was having a similar problem with an iPhone app, but nobody knew how to fix it.

    Any ideas?

  2. Sander, Dec 2, 2010
    Last edited: Dec 2, 2010

    Sander macrumors 6502

    Apr 24, 2008
    Perhaps you built the executable for a different CPU than you have in your computer..? Or you switched Garbage Collection on for your app but not for the library? Scrutinize your build settings for differences between your Debug and your Release versions...
  3. isthisonetaken thread starter macrumors regular

    Jun 29, 2006
    But what I was trying to say is that for my Debug version, nothing changed. I was using it throughout development of the application. Then it sat for 40 minutes, nothing was changed in it and then when I went to demo I got the error. Switching to Release allowed me to demo the app.

    What I don't get is why changing nothing all of a sudden breaks it?
  4. lee1210 macrumors 68040


    Jan 10, 2005
    Dallas, TX
    You don't know what, if anything changed. You didn't mean to change anything. Maybe one of your classmates hacked your machine and changed the file to sabotage your demo. Unlikely, but something did change. Without a copy of all of your files in the previously-working state to compare to the now-broken state, we can't really diagnose it. Perhaps you could create a new project the compare the Debug settings to that in the now-broken project?


Share This Page