Weird graphical glitch in Safari; seen it?

joewillmott

macrumors regular
May 22, 2012
169
0
England
I can't see the line thing being fixed anytime soon. Had it on an old 2009 MBP running Lion, had it on my rMBP running ML and got it on my MBA running ML with Safari 6. There's no way Apple don't know about it, I am guessing they all use these devices in their offices and they browse the web so will have seen it long before any of us... but it still exists so they clearly don't care.

Although it's a small bug, you'd think after a good year+ they would've fixed it!

It's not in a lot of sites, but it has existed for a long time. It used to really annoy me, but not so much anymore.
 

Mr. Retrofire

macrumors 603
Mar 2, 2010
5,040
451
www.emiliana.cl/en
I can't see the line thing being fixed anytime soon. Had it on an old 2009 MBP running Lion, had it on my rMBP running ML and got it on my MBA running ML with Safari 6. There's no way Apple don't know about it, I am guessing they all use these devices in their offices and they browse the web so will have seen it long before any of us... but it still exists so they clearly don't care. Although it's a small bug, you'd think after a good year+ they would've fixed it!
Please report the bug:
http://www.apple.com/feedback/safari.html
 

apb87

macrumors member
Apr 26, 2010
86
98
I have the issue in Safari with the integrated card running also on a 2010 15" MBP. I also have an issue with how the 'crosshair' displays when I do cmd+shift+4 and move the crosshair around. Anyone else experiencing it? It works just fine when the nVidia card is in use.
 

zeeklancer

macrumors regular
Jan 1, 2008
134
0
I just want to point out that the weird white line on macrumors happens for me on my rMBP 15 inch ONLY when I load the page am I am on the integrated graphics.

If I launch a program that forces the dedicated graphics such as iPhoto and then refresh the page the line problem does not happen.

EDIT: apparently I did not read the first page.
 
Last edited:

maryfumster

macrumors newbie
Nov 23, 2012
5
0
Its a rendering issue with Webkit. It can easily be "fixed" by adjusting the CSS of the web site you're visiting.

http://stackoverflow.com/questions/12062582/stray-vertical-line-above-965-pixels-with-border-radius-in-safari
This is clearly Safari issue, because all other browsers with WebKit engine render same pages fine. Your proposal is interesting, but not useful. How I can adjust CSS of all web-sites? Besides, I don't want to. I just want that Apple pay attention on this problem.
 

MyNameIsDave

macrumors member
May 28, 2012
37
0
Blighty
This is clearly Safari issue, because all other browsers with WebKit engine render same pages fine. Your proposal is interesting, but not useful. How I can adjust CSS of all web-sites? Besides, I don't want to. I just want that Apple pay attention on this problem.
You can't adjust the websites, its up to the site owner to do that.

What other webkit browsers are you testing against?
 

maryfumster

macrumors newbie
Nov 23, 2012
5
0
You can't adjust the websites, its up to the site owner to do that.

What other webkit browsers are you testing against?
All website owners should fix Safari bug?
I don't like this idea. Just because it's Safari team should care about that. 4 month (or even more) nobody at Apple pay attention on that. It's crazy!

Chrome render fine, Stainless render fine, Omniweb too.
Safari 6.0.2 (8536.26.17) and Webkit nightly builds has this glitch on Intel Graphics 4000.

Same Safari on the same ML on my iMac doesn't have it.
 

andrewlphilpott

macrumors newbie
May 14, 2012
2
0
You can't adjust the websites, its up to the site owner to do that.
This is definitely not even something that can be fixed by the website owner (unless they go back to early 2000s methods of styling). It is a problem that *only* exists in Safari and it seems to be related to the graphics card. There’s nothing website owners can do about it.

Trust me, it’s even more annoying for web designers than it is for users. Until Apple does something about it, though, we either have to live with it or switch browsers.
 

GuidoH

macrumors newbie
May 13, 2009
7
0
Just bought a new MacBook Air 13", which has the same problems. Had a rMBP for a week, which I returned for some reasons including this one.

Not pleased with this, since I'm a web developer. Can't have that **** again. Don't know if I'll keep it.
 

vpro

macrumors 65816
Jun 8, 2012
1,192
62
problem NOT fixed

actually worse glitching ever.. my machines running lion are all fine and dandy, my 10.8.3 ones though are very glitchy when on youtube especially, glitching at the bottom of the screen, flickers and jitters more frequently than even before.

if it was a graphics card issue - would that mean more than just saffari would be glitching out? would all my other apps run a bit glitchy cos everything is graphics based interface?????????????


thanks.