Weird Hard Drive Corruption - Any advice?

Discussion in 'Mac Basics and Help' started by uvaag, Nov 29, 2012.

  1. uvaag macrumors newbie

    Nov 29, 2012
    I have used macs for 30 years but this has me stumped. Put all my hard drives [10] in a network to search for files but two of them exhibited the weirdest behaviour and im not sure how to fix it.

    hard drive A - a 1tB WD portable with 3 partitions A1 A2 A3
    hard drive B - a 2tB WD powered with a single partition with only films

    The weird part - the first partition on drive A1 [135GB] (a system clone) has replaced (or so it seems) the whole 2TB drive B - so that it reads as being a 135GB disk with no other space. How could it do that without a command or something? Tried Data Rescue 3 which sees the 3 partitions on disk A so probably OK there- but 2TB of Films on disk B nowhere to be seen. It has even renamed disk B from FILM 6 to Macintosh HD. Anyone have any ideas? I tried Disk Drill which also does not see the missing films. as I say never seen this before unless someone has hacked into my network and messed it up...
  2. Prosoft Support macrumors newbie

    Mar 12, 2012

    When you say you were searching 10 drives over the network , how were these 10 drives connected to the network specifically ?

    Also, can you tell me which OS your on and what id the file system of the drives in question ?


  3. uvaag thread starter macrumors newbie

    Nov 29, 2012
    Thanks for the reply

    The system log was turned over so I can't give you the id of the drives - they were connected to a powered hub and an unpowered one to a mac mini - by network I mean my Macbook Pro and my mac mini - I did get numerous messages that a disk was ejected too soon - then it reappeared - It seemed to be the portable was not drawing enough power so I dismissed them - the setup seems to have swapped the portables first partition 135GB with the 2TB powered hard drives data [the first 135GB at least - I have been running Disk Drill for two days to recover most of the film files I hope - it is still running] but it is as if I had run Carbon Copy Cloner to copy one drive to another - it is something I have never come across - a random destruction of the directory of one partition by another


    Sorry Mike I forgot to say the mm is running 10.7.5 and the MB is 10.8.2

Share This Page