Weird iMac restart problem

Discussion in 'iMac' started by msw123307, Jul 28, 2009.

  1. msw123307 macrumors 6502

    Joined:
    Mar 25, 2007
    #1
    I just restarted my imac, and on restart the screen was completely grey and just had the picture of my hard disk logo - and the name (IMAC HARD DRIVE) and i had to click on it, then my computer started.

    Why would this be happening? I do have an external connected, but it's always been connected and i've never seen my computer do this.
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    Check System Preferences > Startup Disk ...

    Make sure the Internal drive is selected.
     
  3. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #3
    Make sure the option key isn't stuck. I'm thinking you would have noticed that by now, but who knows
     
  4. msw123307 thread starter macrumors 6502

    Joined:
    Mar 25, 2007
    #4
    well i went into system pref. and the only two options for startup disk were the main disk and network startup. but it didn't look like anything was highlighted.

    i definitely didn't have any keys pressed down. wonder how this can become unchecked? i had just run a repair permissions on my drive, but thats it. i just restarted after that and that's when the problem occurred.
     
  5. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #5
    ^^ Select the main drive and restart, does it fix it.
     
  6. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #6
    Mine doesn't have any particular HD highlighted in the startup disk pref pane, so I don't think that's unusual.
     
  7. msw123307 thread starter macrumors 6502

    Joined:
    Mar 25, 2007
    #7
    i restarted and it booted up like normal.

    if i go back into my system preferences - startup disk the main HD is now highlighted by default.

    i just wonder why this occurred - what prevented my hard drive from realizing it was still the startup disk? i just don't want it to fail on me!
     
  8. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #8
    Normally, it doesn't ... but, in this case I think it may have gotten changed to the external, but since there is no OS on the external, it just presents the option to boot from the internal.
     
  9. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #9
    Makes sense to me
     
  10. msw123307 thread starter macrumors 6502

    Joined:
    Mar 25, 2007
    #10
    hmm - if that's true - i wonder why mine's still highlighted, strange.
     
  11. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #11
    If you manually select it, it will stay highlighted, IIRC.

    It's weird ...
     
  12. msw123307 thread starter macrumors 6502

    Joined:
    Mar 25, 2007
    #12
    here's what i'm seeing just to clarify. i guess i'm just confused as to how it could have happened in the first place

    [​IMG]
     
  13. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #13
    Meh, stuff happens. I wouldn't necessarily jump to the conclusion that your HD has any problems
     
  14. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #14
    I agree. In the same way that permissions can get borked, a stray process could accidentally change the startup drive to none.
     
  15. msw123307 thread starter macrumors 6502

    Joined:
    Mar 25, 2007
    #15
    i'm sure you all are right. I think in my quest to learn more about the way my mac works - it just leaves me scrounging for answers (like this) sometimes and trying to figure things out. I had this happen and then an issue with incoming connections that i posted about as well - sometimes i just have to remember that weird things happen.

    thanks!
     

Share This Page