Weird international SMS problem

Discussion in 'iPhone' started by bTaryag, Apr 1, 2015.

  1. bTaryag macrumors member

    Joined:
    Sep 8, 2009
    #1
    I have a Verizon iPhone 6 plus. I bought and used it in the USA for a few months. I'm now in Israel, so I popped in a local SIM card. Calls and data work fine. The problem is with texting.

    I have some Israeli contacts and I keep the numbers in the standard international format: +972-xx-xxxxxxx. While in the USA I've texted them and everything was fine. Now that I'm in Israel, it's not working. I get messages from them but I cannot send them.

    What's the problem? The iPhone insists on sending messages to 011-972-xx-xxxxxxx. That was fine in the USA, but outside the USA, 011 means nothing so my texts don't go through. (What's interesting is that this only happens with numbers that I've texted to while in the USA - somehow 011 got stuck to those numbers. However, Israeli numbers that I haven't texted to while in the USA work fine).

    I've tried deleting those contacts, deleting recent calls and texts, turning off dial-assist, resetting carrier settings, restarting the iPhone. Nothing works. This is very annoying.

    Any ideas?
     
  2. mhunter6378 macrumors regular

    Joined:
    Feb 20, 2015
    #2
    The only thought that comes to mind for me is; you started in the U.S. and assuming you activated the phone in the U.S. with your Apple ID, your Apple ID may be retaining the U.S. as you native region. Check the country code associated with your Apple ID and if necessary change it to your current location. Here's a link to a support thread from Apple that addresses a situation similar to what you're experiencing. https://discussions.apple.com/thread/5416934

    Doesn't really explain why numbers you're messaging now, that you didn't while in the U.S., aren't causing an issue but it's worth checking.
     
  3. jdogg836 macrumors regular

    jdogg836

    Joined:
    Jul 28, 2010
    Location:
    Oklahoma
    #3
    Try turning off Dial Assist in Settings > Phone. 011 is the code in any NANPA country (USA, Canada, etc.) that tells the switch you're calling/texting outside of the US. If your contacts are saved right, then this should correct the problem.
     
  4. bTaryag thread starter macrumors member

    Joined:
    Sep 8, 2009
    #4
    Thanks for your response. It seems there's no longer an option to change the country code (see the last reply on the thread you linked where the person also said that). In any case, that seems to be for iMessage issues, here my problem is with regular SMS messages....

    ----------

    Thank you. There is no option for dial assist. (Must be that the local carried doesn't support it). I put back in the Verizon SIM card, turned off dial assist, put back the local SIM, but still have the problem.
     

Share This Page