Weird internet problem... can't connect to search sites??

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Krupke, Mar 2, 2013.

  1. Krupke, Mar 2, 2013
    Last edited: Mar 2, 2013

    Krupke macrumors member

    May 5, 2012
    A very weird problem developed today on my iMac (OSX 10.8). I am no longer able to access most search sites and many non-search sites. Some sites that I can access load with no images and formatting out of place. But it's not a straight connection problem, because I am able to fully access many other sites with full formatting; ie. CNN, HUFFINGTONPOST. As for search sites, I can not access Google, Yahoo, Bing, Dogpile, Webcrawler, etc. But I can access Lycos, Ask, etc. As for non search sites, I cannot access “” or "", but I can access “". This problem occurs regardless of whether I use Safari or Chrome, ethernet or wifi. I can ping the sites I can't access via terminal. Plus, I can access any site if I use an anonymizing proxy service! I'm not in China, so I don't think my ISP is blocking Google. But, they won’t help, because I said I can access all sites on my iPhone via wifi.

    WHAT I TRIED:I tried scanning for trojans with MacScan, it turned up nothing. To ensure nothing is blocking the connections, I turned off the Mac's firewall and stopped Little Snitch. I rebooted the computer and modem, flushed the DNS cache, changed my IP address via DHCP, changed the DNS server to, made sure there was only Apple's default entries in my HOSTS file, and I reset Safari's cache. None of that worked.

    HOW IT STARTED: All I know is, it was all working fine last night before I went to bed. I shut the computer down, and when I got back on this morning, it would not boot (stuck on grey screen, no logo). So I reset the power button and rebooted, and it went back into my desktop. Then once on the net, I found I could not access search sites!

    SOLVED: After a long day of hand wringing, I finally figured out what was preventing certain search and other sites from connecting to the internet. I hope this helps whoever may come across this in the future....

    Being just a couple of days into the "Mac" thing, I never would have guessed it in a million years but... turns out it was not my ISP playing "Kim Jong Il" on me. The inability to access certain web sites was caused by Apple's system of caches. ( I did not even know it had a system of caches!). I'm not sure which one, but Im guessing the user cache. One of these mothers was over 1gb in size! I cleaned them all out at once, using "Cache Out X" and "Applejack" (3rd party software. 'Cos Apple does not think to include its own cache cleaning ability within the system menus! Seems that the geniuses at Apple want to make sure that if their customers are ever smart enough to figure that OS X has crippled their internet connection, well they won't make it easy for said customers to fix this arcane problem!).

    One of the nasty side effects of this cache cleaning business, is that I had to install my last pass extension in Safari. Well, that's the first symptom. I've yet to find out what else this broke.....

Share This Page