Weird iPad/iCal syncing problem (waaaay to many entries)

Discussion in 'iPad' started by kriista1234, Apr 13, 2011.

  1. kriista1234 macrumors regular

    Joined:
    Jan 12, 2008
    #1
    So I got an iPad 2 and when going to set it up as a backup of my old iPad it gives me this screen.

    [​IMG]

    You can't see it from there but I have about 1000 of that same iCal entry.

    That on it's own isn't so bad, but the part I don't understand is that I don't have an option to override the iPad iCal with the one from my computer.

    I can only override my computer iCal (with this outrageously duped version).
     
  2. laurenr, Apr 13, 2011
    Last edited: Apr 13, 2011

    laurenr macrumors 6502a

    Joined:
    Jan 9, 2008
    Location:
    California
    #2
    From your description, I am guessing you are a MobileMe member, and you are syncing your data from your Computer AND your MobileMe account. If you have set up syncing with the latter, you must uncheck all data syncing via iTunes (when your iPad is connected) for your Calendar, and probably your Contacts too.

    Are you on a Mac or PC? Not knowing, I can offer some interim advice. On your main computer, open your Calendar application and delete all duplicates. (For PC users, you can do a search for utilities that can do the job for you). Make sure your Calendar is exactly as you would like it to appear on your iPad.

    Connect your iPad, and in your iTunes settings, deselect all syncing of the relevant data - your Calendar for sure, and anything else, like Contacts, Notes, etc that would risk duplication, as the Mobile Me account handles this function.Apply.

    Once the above is complete and the iPad is no longer connected to your computer, go to your Settings (on the iPad)-Mail, Contacts and Calendar. In this instance, select Calendar settings, and switch them to OFF. Select the option to "Delete from my iPad". This will temporarily erase all your calendar entries. At this point you can check on your main computer that your Calendar is indeed duplicate free, and set up exactly as desired.

    Next, back to the same iPad settings - switch the Calendar back to on, and now select the option to "Merge with Mobile Me", as shown here:

    [​IMG]

    In a few moments, your new Calendar/s will appear, fresh and clean, without all those duplicates.

    Do the same with your Contacts, Notes, or any other iPad App that has Mobile Me syncing capabilities.

    Hope that helps!:)

    Note: the above advice assumes that a Mobile Me account has been set up to handle syncing of the relevant items.

    Edit: sorry, from your screenshot I just noticed that you are indeed on a Mac.:eek: Same advice still applies.
     
  3. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #3
    I do have a mobileme but only the free version (for find my ipad) so it doesn't do any syncing at all.

    I'll try doing the don't sync, and delete ical entries then sync it again after that.

    Isn't there a setting somewhere (on the iPad) to override from computer on next sync or something like that?

     
  4. laurenr, Apr 14, 2011
    Last edited: Apr 14, 2011

    laurenr macrumors 6502a

    Joined:
    Jan 9, 2008
    Location:
    California
    #4
    Are you using a trial version of MobileMe? This could still account for the weird sync issues.

    On your iPad, check to see that there are NO duplicate calendars by clicking on the "Calendars" tab on the top left corner of the open App:

    [​IMG]

    This is often the cause of multiple entries of the same event. I would do the steps I listed above, turning off all syncing in your iPad settings. If you are ONLY going to sync your data when the iPad is connected to your computer, then check the relevant items in iTunes that you want synced to the iPad.

    The only other factor I can think off, is that you have a calendar setup elsewhere, for example, Google/ Yahoo (or a similar service), where the settings are set to "Push" in the "Fetch New Data" settings on your iPad in the "Mail, Contacts, Calendar" tab. If you look at the pic above, you see only ONE "group" of calendars, the "MobileMe" one. If you have a second group listed, eg Google/Yahoo, it could explain the duplicates.

    To illustrate - I also have a Yahoo email account, and because I do now want the duplicate Calendar entries, on my iPad, the settings for the Yahoo Calendar are permanently set to the "Off" position:

    [​IMG]
     
  5. kriista1234 thread starter macrumors regular

    Joined:
    Jan 12, 2008
    #5
    In iTunes there was a setting to copy all of the ical events from my computer to the iPad on the next sync. I ticked that and hit apply and it seems to be alright.

    I don't have the mobileme trial, just the free version that does nothing.

    It just seems weird that it wouldn't give you an option out of the gate for using the computers version of stuff.

    Thanks for the help.
     
  6. laurenr macrumors 6502a

    Joined:
    Jan 9, 2008
    Location:
    California
    #6
    I edited my post above, added some info, check that to ensure you do not have a repeat of this problem. I just finished helping my Sister with this identical issue a few days ago, and it was indeed the case that she had a Calendar set up with another service.
     

Share This Page