Weird Ipad2 WiFi Issue

Discussion in 'iPad Tips, Help and Troubleshooting' started by Howard54, Jul 28, 2011.

  1. Howard54 macrumors member

    Joined:
    Oct 16, 2009
    #1
    I have read about wifi connectivity issues with the Ipad2 and I ran into a weird similar problem today.

    I was in a business office with an open wifi connection. My ipod touch connected just fine. However, my ipad2 showed it was connected to the network with a strong signal strength but would not connect to the internet or let me retrieve mail. When i compared the IP address and Subnet mask from my ipod touch and ipad2, I saw different settings. I tried all the recommended fixes (e.g., reset network, forget network, reboot, turn off Safari auto-fill, clear cache, cookies, etc.) with no luck.

    I went to see the office's general manager and he also had an ipad2. He was connecting to the router just fine with the same settings as my ipod touch, so it is not the router causing the problem. Why is my ipad2 not working but his does work on the same network? Why am I getting different network settings than his ipad2 and my ipod touch?

    Any ideas how to fix this? Thanks.
     
  2. hac82 macrumors newbie

    Joined:
    Aug 24, 2011
    #2
    I would be interested to know this as well as I am having the exact same error where one iPad2 connects via DHCP and the other one just 5 feet away needs to connect via Status assignment.
     
  3. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #3
    I have the same issue at work with an AirPort Express. I'm connected, but never get assigned an IP. FWIW, turning Wi-Fi off and then back on usually fixes it.
     
  4. jaseone macrumors 65816

    jaseone

    Joined:
    Nov 7, 2004
    Location:
    Houston, USA
    #4
    It is likely related to the number of devices connected to the wifi network, it happens all the time to me with open hotspots when traveling no matter the device I'm trying to use.
     

Share This Page