Weird iPhone 7+ Camera Issue (software or hardware?)

Discussion in 'iPhone' started by Jayson A, Nov 13, 2016.

  1. Jayson A macrumors 68000

    Joined:
    Sep 16, 2014
    #1
    While I was out and about today, I decided to take some portrait photos. All was going well, when suddenly the camera app froze. It paused with half the screen black and the other half with a frozen preview of the last thing the screen displayed. I could do anything else in the app, including switching camera modes (which didn't make the camera come back to life) and browse previously taken photos.

    After a bit of playing around in the photo browser (inside camera app), I switched back to camera and it was working again! So I took a couple of photos, then it froze again... same thing... so at this point, I just decided to shut my phone off and turn it back on.

    I held the power button and did the "Slide to Shutdown" thing. The screen went black... however, it wouldn't shut down. The screen stayed black for a while and I could still press the home button and feel the haptic feedback, so I knew it wasn't off.

    So at this point, I hard reset my phone. That worked. Phone restarted and I booted up the camera app. Same thing... it worked for a few seconds, then it froze again. UGH. This time I was able to shut my phone down the correct way and reboot it.

    This is when I figured it must be a glitch with the portrait mode (I'm running 10.2 beta 2 by the way), so I decided to try the camera WITHOUT touching portrait mode. Still froze. So I decided to try a non-Apple camera app which also froze the same way, but the rest of the app worked.

    I'm beyond frustrated at this point. So I decided to try some software things. I turned off iCloud Photo Library and put my iPhone into Airplane mode. After doing that, I opened camera app, took a few photos, tried different camera settings and styles. Everything was working as it should. This time I could not get the camera app to freeze. I tried the third party app and that was fine too. This is directly after I turned off iCloud Photo Library and turned on Airplane mode (I didn't restart or anything).

    So now with the camera working properly, I turned OFF Airplane mode and turned ON iCloud Photo Library. Went back to camera app, all is well. Portrait mode working perfectly fine and all other camera settings working fine. Camera is fast and responsive again.

    Since doing that, I've been opening the camera app and playing around in it TRYING to get it to break again and it keeps working perfectly. What the hell!

    Anyways... at first it seemed like I was having a hardware failure of some sort, but after toggling Airplane mode and iCloud Photo Library, it seems to have completely cured it, so perhaps it was a software issue? It's baffling to me as to why Airplane mode and/or iCloud Photo Library would've fixed this.... I mean... why would a third party app also freeze the same exact way? I'm aware that the third party app probably just uses Apple's camera API, so it's basically the same as the stock camera except for a different interface and some extra features, so that could explain why that App froze as well... maybe the camera API was having an issue (which seems kind of odd considering that I restarted a few times and that didn't solve the problem)

    Sorry for the long post, but can anyone shed some light on this? Has anyone else had similar camera freezing issues?
     
  2. bluespark macrumors 65816

    Joined:
    Jul 11, 2009
    Location:
    New York
    #2
    Uh, you're running beta software? The point of being a beta tester is to report issues to Apple so they can fix them. Do that and move on. If you're "beyond frustrated" because something doesn't work properly, then you probably shouldn't be using beta software on what sounds like your main phone.
     
  3. Pez555 macrumors 68000

    Pez555

    Joined:
    Apr 18, 2010
    #3
    Stopped after reading that.
     
  4. Jayson A thread starter macrumors 68000

    Joined:
    Sep 16, 2014
    #4
    Yes, I'm running a beta, but do you think it was a software issue, or is my hardware starting to fail?
     
  5. Jayson A thread starter macrumors 68000

    Joined:
    Sep 16, 2014
    #5
    Got my iPhone replaced today. The camera pretty much flat out stopped working. I even tried 10.1.1 to no avail.
     

Share This Page