WEIRD iTunes error!

Discussion in 'Mac Apps and Mac App Store' started by ViPa, Oct 7, 2008.

  1. ViPa macrumors 6502a

    Joined:
    Dec 4, 2007
    #1
    this is what happens when i try to open iTunes..then nothing happens after i hit OK
     

    Attached Files:

  2. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #2
    Re-install iTunes?
     
  3. David G. macrumors 65816

    Joined:
    Apr 10, 2007
    Location:
    Alaska
    #3
    The current version at that.:p
     
  4. ViPa thread starter macrumors 6502a

    Joined:
    Dec 4, 2007
  5. ViPa thread starter macrumors 6502a

    Joined:
    Dec 4, 2007
    #5
    okay i tried reinstalling itunes...and it installed successfully but im getting the same error..i didnt uninstall the previous version though, im afraid of losing all my files
     
  6. Ivan P macrumors 68030

    Ivan P

    Joined:
    Jan 17, 2008
    Location:
    Home
    #6
    It shouldn't delete any of your files when you uninstall it. Just to be safe:

    Open Finder -> open your Music folder -> Copy your iTunes folder to somewhere else on your hard drive (such as the desktop).

    Uninstall, reinstall, and then open Finder again and check the Music folder. There should still be an iTunes folder in there with all your files in it. Open iTunes and all your music and videos should be in there already.

    If it isn't, open Finder, open your Music folder, then the iTunes folder, and there will be a library file called something like 'iTunes Library' (it's the iTunes logo with LIB written under it). Open the iTunes app, double click on the library file, and it should import your library straight back into iTunes. If you don't have the iTunes folder inside Music, copy the one you put on your desktop into it.
     
  7. J71 macrumors member

    J71

    Joined:
    Jul 19, 2008
    Location:
    Norman
    #7
    I just had some weird thing happen to my (oldie ;) but a goody!) 30GB iPod Color. I tried to sync up some new songs I recently ripped and I was getting a copy error on some albums. I disconnected the iPod and reconnected and then iTunes (running v8.01) could not find the iPod. I tried to eject the iPod to the trash but no go and it was also hosing up my Mac.

    Finally after a couple of reboots and a few curse words, I removed iTunes and downloaded the program and reinstalled, but still no go. Finally I connected up the iPod to iTunes on my Vista notebook and restored the iPod. I then connected the iPod back to my Mac and had to run another restore to format the iPod back to Macintosh and now all is back to normal and I can sync without issues. (Glad the iPod Touch is not OS dependent. Are the Nanos that way too?)

    So guess what? The above turned out to be a total waste of freaking time!!! I did figure out the problem. It wasn't iTunes, it was the way I connected the iPod to my Mac which was working fine before today but now seems to have a problem. What I was doing was connecting the iPod USB cable to a separate USB cable already connected to my keyboard. The reason for this is to make is easier to connect my digital camera or flash drives rather then directly to the keyboard since this is a little faster to switch out items. The USB cable is fine, just connected my camera and iPhoto just launched.

    Ahh; isn't that how it goes?! Anyway, just sharing my little exciting time with my iPod tonight.
     

Share This Page