Weird iTunes Lag Problems

Discussion in 'Mac Apps and Mac App Store' started by Kee123, May 24, 2008.

  1. Kee123 macrumors member

    Joined:
    Jan 6, 2007
    #1
    All of a sudden my iTunes has been acting strange. I've no idea what causes it, but it happens out of the blue. Sometimes it's fine, sometimes not.

    The issue seems to happen when I'm skipping through songs, I then try to scroll through my library and it's fairly jerky, not smooth like normal. Then my Macbook fans start coming on. I quit iTunes, but it restarts itself, so I have to quit again.

    It's not caused by the latest update, cos I've had that since it was out and the problems have just started.

    My iTunes Library is just coming up to 14gb, but I don't think that would be the problem?

    My Macbook is 1.83ghz Core Duo with 1GB RAM.

    Thanks!
     
  2. MisterEd macrumors 6502

    Joined:
    Jan 2, 2006
    #2
    That's weird, over the last week mine has started acting in the same way. It's an intermittent problem, but when it's happening it will freeze for about a second every 5 seconds or so. It can be really frustrating when scrolling through the library or doing anything more than listening to music (the music continutes playing during the freezes). Sometimes the fans will kick in too.

    I'm on a MacBook C2D 2.0 2GB Ram, 250GB HD.
    My iTunes library is approaching 40GB but I have pleeenty of space left!

    If anyone could suggest any possible causes I'd be really gratefuly, I originally thought it was the last.fm application slowing it down but that has since been trashed and it's still the same.

    Thanks
    Ed
     
  3. Kee123 thread starter macrumors member

    Joined:
    Jan 6, 2007
    #3
    That's strange that you have the same problem.

    Now that you mention Last.fm, I did think it might have been that too, cos I started to have the problems after that had updated.
     
  4. Kee123 thread starter macrumors member

    Joined:
    Jan 6, 2007
    #4
    http://www.last.fm/forum/34905/_/408841

    Found people having similar problems there, I'll try the suggestion(s) there and see how it goes.

    Edit - No, still doing it.

    Edit 2 - Definitely is a Last.fm problem, completely uninstalling it fixed the problem for me. Time to find an alternate scrobbler.
     
  5. MisterEd macrumors 6502

    Joined:
    Jan 2, 2006
    #5
    Hmm, think mine may now be fixed after a complete uninstall and reboot. Time will tell I guess...
    According to some of the replies in that thread they've fixed the problem in the latest build, so maybe try installing that if you're brave!

    Thanks
    Ed
     

Share This Page