Weird keyboard problem - "3" "E" "D" "C" keys not working properly

Discussion in 'Mac Basics and Help' started by ahe, Apr 24, 2006.

  1. ahe macrumors member


    Feb 12, 2003

    one of my colleagues recently bought a second-hand PowerBook G4 15" 1.67 GHz, and today faced a problem we haven't been able to solve yet.

    The problem itself is that keys "3" "E" "D" and "C" do not behave as they should. When writing text, keys "3", "E" and "C" do not enter any of their corresponding characters, while key "D" functions as the F1 key, decreasing the screen brightness. We have tried connecting an Apple wireless keyboard and its "3" "E" "D" and "C" keys work perfectly, opposite to what happens with those keys in the built-in PowerBook keyboard. By the way, NumLock is NOT enabled. We have also checked extensively all the keyboard setting we can think of, to no avail.

    We figure it could be related to some keyboard shortcut that has accidentally triggered this, but my friend doesn't remember if he did such a thing. The only thing he remembers is that he had been using GarageBand before he encountered the problem, although this may not be relevant at all. Funny thing, these 4 keys are adjacent, that could mean something :rolleyes:
    Any suggestions? Thanks in advance,

  2. calebjohnston macrumors 68000


    Jan 24, 2006
    I'm afraid that's probably going to need to go in to get fixed; hope it's under warranty.
  3. Reflow macrumors 68000


    Mar 30, 2005
    Maybe you had something spilled on it. I had the similar problem with my iBook so I just got a new keyboard
  4. tonywalker23 macrumors regular

    Dec 21, 2003
    i could be way off, but when i was in the pc world :( i heard of prank programs that remap keys as a joke,

    not sure if its possible on mac though ...?
  5. ahe thread starter macrumors member


    Feb 12, 2003
    Hi everyone,

    thanks for your replies. My friend tells me the problem was gone this morning when he started using his PB again, so I guess it could have been because of a liquid that has evaporated (the palms of his hands sweat big time, sounds stupid but maybe that's the cause :rolleyes: )

    Thanks again.
  6. Cybix macrumors 6502a


    Feb 10, 2006
    Western Australia
    One of the BRAND NEW MacBook Pro's that I bought had this problem.

    firstly resetting the pram and pmu fixed it, after a while it got worse and worse. only on this machine it was the 6YHN and space bar. (a line down the keyboard)..

    we had the unit replaced.
  7. calebjohnston macrumors 68000


    Jan 24, 2006
    I believe I remember talking to you about that Cynix a while back. I was going to refer him to you, but I couldn't remember your name.

Share This Page