Weird Leopard behavior

Discussion in 'macOS' started by infinitbelt, Jan 14, 2008.

  1. infinitbelt macrumors newbie

    Joined:
    Jan 14, 2008
    #1
    Hi,

    I don't know what happened to cause the problem (might have been the clearing of User Cache) but for some reason my mac is acting weird. For example, when I have an application open and I click the red button, it used to just hide the application, now it just quits it completely.

    Also, Microsoft Office 2004 opens fine and lets me view my documents but whenever I try to print or save as PDF, it just quits without any error messages.

    Why might this be happening?


    Thanks!
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    The printing problem I have no immediate suggestion about other than that the print subsystem is obviously crashing the apps, but about the red button:

    Are you sure that's not happening in apps that are supposed to auto-quit when you click the red button? Some apps (System Preferences and Address book, for example) automatically quit themselves when the last open window is closed, so when you click the red button they go away.

    If it's happening in, say, Word, and/or you're getting an "Unexpectedly quit" error afterward, that's different.


    Thing to try: Create a new user and see if the same problem happens. If not, there's something messed up in your preferences. If so, your system is screwed up and unless you've installed something recently that's causing problems (any hacks or utilities?), the most likely solution is a reinstall. Maybe you can get away with running a combo update (hopefully 10.5.2 tomorrow or the day after), but a clean install might be required depending on how bad things are.
     
  3. infinitbelt thread starter macrumors newbie

    Joined:
    Jan 14, 2008
    #3
    I tried creating a new profile and it was exhibiting the same behavior with the red button. The apps close that are not supposed to (Safari, Mail, iChat, iCal). Some apps like iTunes behave fine. The only utility I installed yesterday was Ice Clean but I uninstalled that already. I also installed adobe photoshop, could that be causing it?

    Thanks!
     

Share This Page