weird memory problem?

Discussion in 'MacBook' started by Good-Apollo, Jan 26, 2009.

  1. Good-Apollo macrumors newbie

    Joined:
    Jan 26, 2009
    #1
    I find this problem slightly weird, and after researching I cant for the life of me think what the problem is... here goes

    I upgraded the memory in my macbook 13" 2ghz a few months ago with some ram I bought off play.com, this week I went and bought the same stick of ram with the intention of upgrading it to 4gig, however the macbook doesn't like the new ram alongside the upgrader 2 gig,

    for example, I can still run my original 512mb and the 2gig old stick, I can run the new 2 gig stick on its own, or with the old 512mb, but I cannot get the 2x 2gig sticks to run together, it gives me the 3 bleeps?

    they don't look identical (even though I thought they should be) but its clear they both work, but why not together?

    any suggestions?
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    Sounds like 2 different types of memory. Macs are fickle about the kind of memory they use.
     
  3. Good-Apollo thread starter macrumors newbie

    Joined:
    Jan 26, 2009
    #3
    I can only put it down to the fact that they are clearly different memory sticks (despite they're supposed to be the same) but they shaped differently - is the problem, as my system (according to crucial.com) can hold upto 4gb

    Maximum Memory Capacity: 4096MB
    Currently Installed Memory: 2.5GB
    Available Memory Slots: 0
    Number of Banks: 2
    Dual Channel Support: Yes
    CPU Manufacturer:
    CPU Family: Intel Core 2 Duo 2 GHz
    CPU Speed: 2000 MHz
    Although the memory can be installed one module at a time, the best performance comes from using matched pairs of modules


    maybe its because they're not identical, but then why would it run with the old 512mb stick alongside it? confused :confused:
     
  4. walldawg84 macrumors member

    Joined:
    Sep 29, 2008
    #4
    It sounds as if the chip's not the right type ... or there might be a problem with it?? ... You mentionned it was a different shape??

    Is it an older macbook or one of the new aluminium ones?

    I got my blackbook mid-2007, and upgraded to 4GB of RAM soon after, not realising that the chipset can only support 3GB, so that's all it uses. In saying that, though, I bought both chips at the same time from the vendor (can't remember who I bought it from) and it worked grand.

    Have you tried contacting play.com to see if they changed supplier of the chip since you last bought it or anything, see if there's any inconsistencies in their supply??
     
  5. Good-Apollo thread starter macrumors newbie

    Joined:
    Jan 26, 2009
    #5
    Well what i've done is explain the play.com the problem, and their shipping me out the same piece of ram, so im going to try the two new 2gig sticks and see if that works, if it does then ill send them back the old 2 gig one back

    ill keep you guys posted
     
  6. DiSFLyLaTiNa macrumors regular

    Joined:
    Jan 8, 2009
    #6
    maybe your machine doesn't recognize 4gb? maybe it only recognizes up to 3gb? i don't think there would be any other explanation if both sticks can run alongside the 512mb.
     

Share This Page