Weird network issues in 10.5.6

Discussion in 'Mac OS X Server, Xserve, and Networking' started by zero0zero, Apr 21, 2009.

  1. zero0zero macrumors newbie

    Apr 21, 2009
    I'm having some pretty random problems with my network and i'm having a hard time trying to figure out what the issue is. I've tried my work laptop on the same network and it works fine for everything my personal macbook pro doesn't.

    Here are a couple things that aren't working:

    Some http traffic times out. Sometimes sparkle updates don't work, in particular tweetie and transmission are not able to update. Also certain web sites break (either totally or partially). For instance won't load at all (pinging works fine).
    I've tried looking at the traffic using charles ( and it says it sends the headers but it never gets a response. The charles log for is attached. What works works fine though, good and reliable speeds etc.

    I got an airport extreme to share my external hard drive over wifi. Doesn't work. Works fine on my work mbp.

    I'm not sure if these are related but as neither works on machine A and work on machine B + both are network related it brings up suspicion.

    I've tried changing (and resetting) network settings using cocktail. Tried with no apps running, reboot etc. I don't have access direct to my router (it's my landlord's).

    Any ideas where to start looking / what to try / etc? Could this be hardware related (my machine is 1st gen mbp)? Any help greatly appreciated!

    Attached Files:

  2. mrfrosty macrumors 6502

    Oct 1, 2005
    Sounds like an MTU issue to me.

    Send out some pings with the DF (Dont fragment) bit need to do various sizes from 1500 downwards.....If it is MTU you could possibly fix it on the router with an MSS adjustment, if you have no access to the router then you can probably just get a utility or something to lower the MTU of your Mac.

    If pings of 1500 get through with the DF bit set then its probably not MTU......
  3. zero0zero thread starter macrumors newbie

    Apr 21, 2009
    Ping -d goes through fine (results are identical without -d). Also i've tried setting various MTU values on OS X without any obvious changes. Thanks for the tip though

    I tried installing OS X on a firewire drive and booting from it. Clean software, same hardware. Same results! This would indicate that it's probably not a software related issue since the same tests work fine with the other mbp (latest version). Gets a big 'wtf' from me as most other stuff works as it should. Is there anything that can be done here except buying a new computer? Firmware tweaks/updates/etc?
  4. zero0zero thread starter macrumors newbie

    Apr 21, 2009
    Looks like the problem is cachefly. I'm guessing Adobe hosts their assets there, both tweetie and transmission use cachefly to host their builds, even loads without images. Also videopodcasts that are hosted on cachefly won't download (it worked fine before but now the last episode that came in is about a month ago).

    Again, everything else works fine but i get 0 response from cachefly. Any ideas how this is possible / if there's anything that can be done? Thanks

    Attached Files:

Share This Page