Weird NFS problems; works in terminal not in Finder?!

Discussion in 'macOS' started by gnomeisland, Jan 31, 2011.

  1. gnomeisland macrumors 6502

    Joined:
    Jul 30, 2008
    #1
    Setting up a FreeNAS server and trying to set up an NFS share. I got the share to mount but in the Finder whenever I copy anything to the share I get an "error -36" and 512kb file. On a lark I tried copying some files via 'cp' in the terminal and it works like a champ.

    I've looked around online and several sources mention that Mac OS uses and insecure port. I've tried their workarounds (not success) but then no one seems to mention NFS working in the terminal but not in the Finder. Suggestions?
     
  2. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #2
    File a bug with Apple? Finder might be trying to write extended attributes to the file and NFS doesn't support it.

    I am unsure what you are trying to do with your freeNAS server, but I would recommend that you try netatalk. It shares your Unix partitions, etc. as AFP network drives. It should work better for Mac OS X.
     
  3. gnomeisland thread starter macrumors 6502

    Joined:
    Jul 30, 2008
    #3
    Oddly AFP, which wasn't working, is now kind of working. I've heard that NFS works better with FreeNAS. At this point NFS is as native to Mac OS X as AFP which is a hold over from yesteryears.
     
  4. tragus.org macrumors newbie

    Joined:
    May 17, 2011
    #4
    I know this is an old thread but I didn't have a Mac in February...


    I have the same problem (without the error -36) on my new iMac. Access to the NFS share works as expected at the shell but Finder won't let me do anything but browse. I've mounted the share with Finder -> Connect to Server and with Disk Utility -> NFS.

    In both cases I then setup a symlink from the actual mountpoint to my Desktop:
    ln -s /net/server/path/to/share ~/Desktop/Test1
    ln -s /Network/Servers/server/path/to/share ~/Desktop/Test2


    I can browse these with Finder but cannot do anything else.

    If I manually mount the share (or create /etc/fstab and add an entry) Finder works as expected:
    mkdir -p /mnt/share
    mount -t nfs server:/path/to/share /mnt/share
    ln -s /mnt/share ~/Desktop/Test3


    In all cases, actions at the shell work as expected.

    I've also noticed that it takes the automounter a long time to recognize that new shares are available or old ones are no longer there. In some cases, it never does even if I kill the currently running automounter or do "automount -vc".

    Any help would be appreciated. I don't mind running with /etc/fstab entries but it would be much cleaner to rely on the automounter's ability to discover shares.
     

Share This Page