Weird power issue with MBP C2D A1211

Discussion in 'MacBook Pro' started by cookieme, May 28, 2010.

  1. cookieme macrumors regular

    Joined:
    Aug 22, 2005
    #1
    When I woke up this morning the magsafe was no longer lit with a green light. It is supplying power to my MBP, but doesn't charge the battery any longer. Very odd indeed! I have performed the following troubleshooting steps:

    - Reset SMC: Didn't help

    - Tested a brand new battery: Didn't help

    - Tested another magsafe: Didn't help

    - Tested different power sockets: Didn't help

    The MBP is receiving power when the magsafe adapter is connected, but not charging the battery!

    I know the MBP is about 3.5 yrs old, but this is extremely frustrating especially as it has happened for no apparent reason.

    I guess that my testing has narrowed it down to a hardware problem to do with the logic board.

    Any suggestions?
     
  2. cookieme thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #3
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    So you've already tried all the troubleshooting steps, then you've taken your adapter to an Apple-Authorized Service Provider or Apple Retail Store for evaluation and replacement if necessary?
     
  4. cookieme thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #5
    Perhaps if you would have taken the time to read my first post:

    you would have realised that I have already tested with another functioning power supply. The result was the same as with my own, thus I can conclude that it is not a power supply issue!

    Anyone can post a link to a support article on Apple's site!

    If someone else has any suggestions I would appreciate hearing them. Thanks.
     

Share This Page