Weird preferences/permissions problems...please help

Discussion in 'Mac OS X Lion (10.7)' started by NewObject23, Aug 5, 2011.

  1. NewObject23 macrumors newbie

    Nov 10, 2009
    I am having a number of different symptoms, none of them very bad, but collected together they are very annoying, and I am wondering if they are all somehow related to some problem with the way OSX is saving (or not saving) my preferences, or writing permissions, or something. Any ideas or fixes would be very much appreciated. I already repaired permissions.

    Whenever I open iTunes, I get a message saying "The volume is turned all the way down." Every single time. Doesn't matter where the volume was when I closed iTunes the last time. I always check the "Do not show this warning again" and say OK, but when I open up iTunes again, it's the same thing.

    I have a few applications that don't work with Lion, so I removed them from the dock. When I restart, they are back in the dock.

    I have changed the mouse scroll direction preference several times. Whenever I restart, the direction switches back.

    I have changed the preferences in Finder to always show all files in the "list" view. Whenever I restart, it switches back to icon view.

    Also, Preview and TextEdit no longer work at all. :confused:

    There might be other things I'm forgetting. I just can't escape the feeling that all of these things are related. Any ideas or fixes?

    Thanks again for any help. :)

  2. robgendreau macrumors 68040

    Jul 13, 2008
    Are you having permissions issues? It sounds like it. Check the permissions on your preferences folder; one problem might be that the applications cannot write the changes to your pref files.

    Try creating a new user and then logging in as that user, and see if pref changes stick with that user.

  3. NewObject23 thread starter macrumors newbie

    Nov 10, 2009
    Thank you partially. I deleted the preferences file for iTunes and it seemed to fix that particular problem. However, deleting preferences and repairing permissions did not fix the problems with Preview or TextEdit.

    Creating another user and logging in as that user "worked," but since I would have to start over completely from scratch with that user (who cannot be automatically logged in), this is not really a good solution for me.

    Any other ideas?
  4. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    I have read here about others having the same issue with Preview and TextEdit.

    I don't know if Apple's support forum would help or not.
  5. robgendreau macrumors 68040

    Jul 13, 2008
    Have you repaired permissions? And checked the Prefs and Library folders for permissions problems? Can you change prefs in other applications without problems?

  6. murdercitydevil macrumors 68000


    Feb 23, 2010
    I had a very, very similar problem with my first Lion install. There were numerous issues with settings not sticking - Finder view options would revert, System Prefs options would never stay the way I wanted, the Dock kept putting icons that I removed back in, etc etc. I knew that it was a permissions problem related to the system not being able to write to plists, but I couldn't find a way to fix it. The problem (I think) for me was that I installed using a USB stick...back when I built my first SL hackintosh, I remember that one of the most stressed points of the guide was to make sure that "ignore ownership on this volume" was UNCHECKED on the USB stick prior to installing. I re-installed with this in mind, and it worked. Now, I don't know if that's actually what fixed it, or if it was the fact that I used the copy of Lion I got from MAS rather than the GM, but the problem went away. When I installed Lion on my MBP, I decided to not risk it happening again, so I used a DVD rather than a USB stick. Sorry that I don't have a solution for you, but you may want to consider re-installing, if it comes to that. I know that in my case, if nothing else, I had a nagging feeling that my system was simply "broken" in one way or another, regardless of whether I fixed the permissions issue or not, so I opted for a fresh install.

    EDIT: By the way, I can't say for sure whether or not permissions are at fault. Why? Well, on my hackintosh, after a clean install (with all settings sticking properly), I checked permissions on my root drive, and saw that my account had "custom access" but with Read/Write privileges. On my MBP, however, after being unable to run a benchmark which required write privileges to create temporary files to test disk speeds, I saw that by default, Lion had only given my admin account "read" privileges. But settings were sticking properly there, as well. I think that if anything, it's safe to say that this is simply a potential bug in Lion. I don't think it depends on the system, nor the privileges per se, I think there's something going on at a deeper level.
  7. srf4real macrumors 68040


    Jul 25, 2006
    paradise beach FL
    Yeah, I'm not going the fresh install route, I can tolerate my preferences getting lost or stolen occasionally. But I am def ready for Lion OS 10.7.2:rolleyes:

Share This Page