Resolved Weird problem, continuously shutdown after safe boot Mavericks.

Discussion in 'Mac mini' started by justperry, Dec 6, 2013.

  1. justperry, Dec 6, 2013
    Last edited: Dec 6, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #1
    Here is what went on before I got into this problem.

    I have Mavericks on both the main system and a second partition, I had some trouble not seeing avatars here on Macrumors so I restarted into the clean Mavericks partition, this didn't help either so I restarted into the main System by holding the Shift key.
    I got to see the spinning wheel and the normal Apple logo together with a loading bar, the bar didn't progress and after about 20 seconds it vanished.
    Then another 10 seconds and the Mac Mini (Late 2012) shuts down.
    When I press the On button on the back again I get exactly the same.
    Nothing I tried helped, it is stuck into the safe boot process and shuts down each and every time.

    No key combinations work.
    *Holding Option to have the boot Manager show up does not work.
    *Resetting NVRAM/PRAM does not work.
    *Resetting the SMC does not work.
    None of the key combinations work, not on a Apple wireless keyboard nor on a wired one.
    I also removed the RAM for a bit, thought this would clear the NVRAM, NOT, I do have the old RAM and that's next.
    Edit: Installing (Original) RAM didn't help either.

    I am pretty sure it is not a hardware failure, I am pretty sure it's just stuck in this Safe boot loop.
    A couple of months ago I tried to install Mavericks on an external, It finished Installing (partly) and whenever I tried to get into recovery I got the message over and over again that the Install failed, even after deleting a certain Install Folder on the External, so I guess this is probably a Mavericks problem.
    The HD is not easily accessible in a Mini otherwise I would try another HD, an external also won't work since I can not choose the external.

    I was thinking about using Target Disk Mode but I think the problem is set in the NVRAM and I can't clear that if I startup this way, if there was a file to delete it would be easy but I think this is not a solution here.

    Any help is appreciated.

    Normally I am the one which helps people here but right now I don't have a clue what to do next.

    (OS X 10.9.1 latest beta)
    Mac Mini 2012, 8 GB RAM

    Update: weird but now I could startup using the Option key with a wired keyboard, problem not solved yet but it is at least starting up from Recovery or a different partition.
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    [[ Update: weird but now I could startup using the Option key with a wired keyboard ]]

    If you're using a wireless keyboard, there is a possibility that some startup key combinations WILL NOT WORK because the drivers aren't loaded first.

    You found the solution -- that is, you used a WIRED keyboard.

    My suggestion:
    - Ditch the wireless keyboard.
    - Use a WIRED keyboard.

    If you do this, I sense things will go much better for you....
     
  3. justperry thread starter macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    Until now I had little trouble with Apple's wireless keyboard, it always sees the keys I press at startup, this was the first time it didn't and even the wired didn't work the first few times.

    Eventually it did but that was only the start of the problems, Diskwarrior reported my disk to be failing but it is not, I wiped (Partitioned) the HD, copied everything back from a backup and I am back up again.
    Heard stories about Mavericks corrupting disks, well, seems to be true, first time this happens to me and I had all OS X versions from 10.0 beta.

    Thanks for the advise though.:)
     

Share This Page