Weird Problem Deleting/Joining in GarageBand

Discussion in 'Digital Audio' started by gvdv, Aug 12, 2011.

  1. gvdv, Aug 12, 2011
    Last edited: Aug 12, 2011

    gvdv macrumors regular

    Feb 18, 2007
    I'm having a problem in GarageBand 9 that I have never previously had.

    When I split part of a region in a Real Instrument track (Audio), delete the part of the region that I have split off, and then join the two parts of the region either side of the deleted 'gap', the part that I have deleted gets reinstated.

    I want to be clear here that I am NOT dragging the two bits of the region either side of the 'gap' (deleted part) next to each other - I the two regions to stay in the same places, and just want to put a bit of continuous silence between them, joining all of them into one region as opposed to having different, isolated pieces of regions which might get accidentally moved at some point.

    This used to work beautifully, and isn't happening in a Software Instrument track.

    I have tried shutting down my Mac Pro, re-starting, and firing up GarageBand all over again, and creating a new song and recording a fresh audio track. I have also tried closing and re-opening the track, but the problem still persists. I have also deleted the Preferences files, re-started GarageBand (and got the 'Welcome' screen, which seems to confirm that the Preferences were deleted), but there is still a problem.

    Does anyone have any ideas about how to prevent/solve this?


  2. Papanate macrumors 6502


    Jul 21, 2011
    North Carolina
    I have tried this 4 times in Garageband. The first time last night the clip when joined behaved as you are seeing it.

    Today I've done it three times in a row (closing and reopening the project each time) and can not duplicate the behavior.

    So...questions abound.

    1. Did you position the cursor before the first clip to be joined?
    2. Did you high light both clips to be joined?
    3. Did you use the menu or the Apple J key command?
  3. gvdv, Aug 14, 2011
    Last edited: Aug 14, 2011

    gvdv thread starter macrumors regular

    Feb 18, 2007
    Hi Papanate,
    Thanks for your reply.

    Yes, I was using the 'Join' function correctly, but I found that I can solve this problem if I do the following:
    1. Split the region
    2. Make the second split, to 'orphan' the part that I want to get rid of.
    3. Delete the 'orphaned' part.
    4. Move the region to the right of the 'gap' (that now exists because of the the deletion of the 'orphan') a bit more to the right.
    5. THEN select that region and the one to the left, and join them.

    It seems to be important to move one of the two regions that you want to join a little further away from its partner just after the deletion of the 'orphan'/prior to joining them.

    It seems that this is a 'prerequisite', because I was getting the problem that I described if I deleted the 'orphan', and then simply tried to join the two remaining parts together without temporarily moving one of them further away. However, it sounds like you didn't have to do this.

    Another workaround that I came up with was to copy-and-paste a piece of silence into the gap left by the deleted 'orphan', and then drag the pasted silence and join it to the two regions to the left and right of it.

    I think that when I have edited previously, I have often moved regions a little, but I hadn't realized that this was a crucial precursor to joining regions together.

    Weird, but happily resolved.

    Thanks, for your help.


Share This Page