Weird problem..network, airport utility, permissions

Discussion in 'Mac Basics and Help' started by Wie Gehts, Apr 1, 2010.

  1. Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #1
    So I'm on the internet and my browser won't connect suddenly. Ok, its happened before, just restart and all is fine. But that doesn't work. I repair persmissions (which had to do with some widget thing, which I've never ever seen before) My wireless is on and says its connected to my airport but my browsers won't connect and network diagnostics just hangs and I have to force quit.

    My next usual fix routine is too open Airport Admin utility, go to configure, change a channel setting and do a reset. Which brings me to another issue.... before it will let me configure, it asks for the airports password. So I do that and save it to the keychain and it appears to have gotten my browsers connected again...fine.

    But now I'm wondering why it asked for the password, which it hasn't done before, so I open the utility again, go to configure and it asks me for the password....despite just previously saving it to the keychain.
    I checked keychain, its in there.
    I did this multiple times...it keeps asking for password, I keep saving it to keychain.

    I get info for the airport utility and it, as well as all my stuff, has 'system' for access privileges...so that should be ok, as it always worked and I'm the only account and person that uses the computer.... which makes me ask.....whats the difference having 'system' or my user account for read & write privileges? Are they just the same thing?

    So this is bugging me....why won't airport utility stop asking for the password and what the heck happened that suddenly all this stuff got cocked up?
    I hate when inexplicable stuff like this happens..

    All this while, I have itunes streaming to the airport from my pc laptop and it was still working even after my mac lost its connection. After a bit I went to itunes on the pc and tried another station and IT would no longer connect.

    But like I said, after I did a reset form the mac, it all connected again...but now this password permission thing...grrrrr
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Have you tried simply turning off your router (and disconnecting the DSL cable) for 30 seconds and then restarting with the cable plugged in? Since your having problems on two machines, I suspect the router is the source of your problems. If that doesn't work, get iStumbler and check to see if your on a channel that doesn't interfere with your neighbors internet. The last thing is sometimes certain devices have problems with routers that automatically change from b to g to n. You might need to pick just g.
     
  3. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #3
    thanks, i'll try that. we did have the power cut off for a second the other day.
     

Share This Page