Weird problem on website?

Discussion in 'Web Design and Development' started by kclimson, Nov 19, 2011.

  1. kclimson macrumors newbie

    kclimson

    Joined:
    Aug 15, 2011
    Location:
    Canada
    #1
    So I have been trying to make a website on my own. Its been going well and am very close to publishing but on occasion my entire website is lowered a coloured bar appears on top http://www.macview.ca/wp-content/uploads.2011.11.Screen-shot-2011-11-19-at-6.10.39-PM.png
    Is there any way to fix that. My website is www.macview.ca
    Edit: my orange bar is sometimes aligned under my logo, but after its refreshed everything is perfect?

    Edit: If someone can fix there problem I'll credit them in my website
     
  2. jared_kipe macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
    #2
    Couple of things that could be going on.
    header nav {} has declared position: absolute; but lacks any positioning information like top: 0; right: 0; (you effectively take it out of the normal flow, but don't position it at a set point)

    It has float: right; assigned but is overridden by .grid_19 to float: left;

    nav should probably not have class grid_19 as it does nothing for it really.

    #Orange has unsupported attribute 'postion: relative;' which I assume is supposed to be 'position: relative;' which is probably why you sometimes get odd behavior on this id.

    h3 has no semi colon on the text-shadow line.

    .post has 'Padding-bottom:' which may or may not parse correctly to 'padding-bottom:'

    Generally speaking, you're using some kind of grid system, but not the way it is intended.
    Example: .grid_19 earlier is floated right instead of using .push_xx or something to move it over.
     

Share This Page