Resolved Weird problem with keyboard mapping : LMP Bluetooth Keypad's "enter" seen as "CMD"

Discussion in 'iMac' started by DanRom, Aug 22, 2012.

  1. DanRom, Aug 22, 2012
    Last edited: Aug 23, 2012

    DanRom macrumors newbie

    Aug 22, 2012
    I've purchased a LMP Bluetooth Numeric Keypad for my mid 2011 iMac (see system's details below).
    Excellent piece of hardware: really does its job.
    (I actually prefer the LMP keypad keys' feedback, rather than the original Apple Wireless ones!)

    However, it worked fine for a day or so, then, the ENTER key ceased to work properly.
    Since then, it is actually seen as a CMD key !!!
    I know that it is likely my fault, because I played with Ukelele and key mapping :( but I cannot restore the keypad to its original settings

    Please note that I am NOT referring to the well known RETURN vs ENTER issue, nor to the combination of CMD and other keys (which is well addressed in FAQ section of the keypad guide).

    This looks like a new, totally different, issue.
    When I press the ENTER key on the LMP Keypad, it works exactly like if
    it is a CMD key on the main keyboard.
    Nothing more, nothing less than that.
    (I double-checked with Ukelele, when I press ENTER on the LMP Keypad,
    the two CMD keys on the keyboard layout light up).

    The interesting thing is that if I pair that same LMP keypad to my MacBook Pro, the ENTER key on the keypad works fine !
    So, the easy deduction, is that the malfunction should be caused by some wrong settings on my iMac.

    I live in Europe, my Apple Wireless keyboard is ISO layout.
    Because of my language settings, the decimal separator on the keypad is seen as a COMMA by default.
    I wanted to change it, as I am used to have it as a DOT.

    So I used Ukelele to play around.
    I successfully managed to have the DOT where I wanted, but since then the ENTER key is showing this weird behaviour.
    I removed Ukelele and all the customisations that I made on the keyboard settings, with no results: I cannot go back to the original ENTER function.

    I have surfed the Internet for a week, trying to find a solution, but
    with no results. I have asked the LMP's support (very responsive and kind) but - as I expected - they are at least as confused as me... (besides, that is not a device's problem...)

    Have you any ideas?
    Thank you
    - DanRom -

    My system is an i Mac 21.5 inch, mid 2011
    running Mac OS X Lion 10.7.4 (11E53) on an Intel Core i5 2.5 GHz
    The Apple Wireless is ISO layout
  2. DanRom thread starter macrumors newbie

    Aug 22, 2012
    One more piece of information:
    I made an attempt deleting the "Library/Preferences/"
    and "Library/Preferences/"
    then restarted.

    Unexpectedly, the system booted in Safe Mode, but the ENTER key on the LMP Bluetooth Keypad worked fine :)

    I restarted again.
    The system logged in normal mode, and the ENTER key went back to its weird behaviour (as CMD key).

    I am still confused! :(
  3. DanRom thread starter macrumors newbie

    Aug 22, 2012
    Solved !!!

    My fault.

    The problem was due to "DoubleCommand", a key mapping app, which I had uninstalled improperly, and - for some reason - had the option "Enter key acts as Cmd key" checked.
    I reinstalled it, unchecked the option, and all went back to normal :D

    Now I can fully enjoy the features of my LMP Bluetooth Keypad again :)
    (BTW: the guy at LMP's clients support really tried all what he could do to help me! I'm really impressed)

Share This Page