Weird Problem with my new iPhone

milan03

macrumors 6502
Original poster
Jul 16, 2002
440
13
New York City
Just bought the iphone from the 5th avenue store in NYC (sunday), and plugged it in, itunes opened, and gave me this weird message:

"iTunes could not connect to the iTunes Store. A secure network connection could not be established.
Make sure SSL 3.0 or TLS 1.0 is enabled in the Internet Options control panel, then try again."

Went to the control panel, made sure that those options are checked, still nothing.... Uninstalled/reinstalled the latest iTunes, still nothing... Called at&t.... wow they are closed on sundays... splendid....

Does anyone know what should i do, and has anyone experienced the same issue? Whats the solution?

P.S. I googled about this issue, and the "solution" is what I already tried, but it obviously doesnt work. Also, the no activation on sunday screen looked totally different from my error message.

Thank you in advance. :)
 

Bostonian1976

macrumors member
Jul 2, 2007
78
0
download the latest itunes, install it, restart your computer

Edit: oops you did the install. Did you restart?
 

milan03

macrumors 6502
Original poster
Jul 16, 2002
440
13
New York City
What O/S and version are you running.

what version of iTunes do you have installed.

any firewall software installed?

I'm running Vista Ultimate 32-bit, updated with the latest updates, and downloaded the latest iTunes today. Have no firewall, even the windows firewall is disabled.

This is really upsetting me right now :(
 

AJsAWiz

macrumors 68040
Jun 28, 2007
3,252
342
Ohio
Just bought the iphone from the 5th avenue store in NYC (sunday), and plugged it in, itunes opened, and gave me this weird message:

"iTunes could not connect to the iTunes Store. A secure network connection could not be established.
Make sure SSL 3.0 or TLS 1.0 is enabled in the Internet Options control panel, then try again."

Went to the control panel, made sure that those options are checked, still nothing.... Uninstalled/reinstalled the latest iTunes, still nothing... Called at&t.... wow they are closed on sundays... splendid....

Does anyone know what should i do, and has anyone experienced the same issue? Whats the solution?

P.S. I googled about this issue, and the "solution" is what I already tried, but it obviously doesnt work. Also, the no activation on sunday screen looked totally different from my error message.

Thank you in advance. :)
When you call, if I were you, I'd select "speak to an Apple Representative" from one of those sub menus. I think you have to select something like calling about an iPhone. AT&T reps would, most likely, be clueless on this topic :apple:
 

milan03

macrumors 6502
Original poster
Jul 16, 2002
440
13
New York City
I can't believe that both ATT and Apple tech support isn't 24/7. There is absolutely no one in their tech offices right now... omg :eek: